Getting Better Performance of Cubase 7.5 in W7?

Cubase 7.5 in W7 is not accessing the full potential of my CPU.

In Cubase the “VST Performance” window shows a 90% average load, though in Windows Task Master running behind Cubase shows 23% CPU being used (see image attached).

I have 12GB of RAM, the computer is using less than 3GB. I am running a 1024 buffer size (the maximum offered). I have the “multi-processing” and “asio-guard” options turned on. None of the individual CPU’s in Task Manager are above 50%, they range from 50% to 10% (see attached). I have the latest motherboard chipset installed. I have the latest Lynx Soundcard drivers installed.

Are there any tweeks that I can do in W7 to get better performance from Cubase?
I have looked at this article: - and followed it except for points, 6, 7 & 8, as bios doesn’t seem to offer these options.

Are there any tweeks in Cubase that I can make to get a better performance from Cubase?

Will Cubase 8’s “Massive Engine Rebuild” & “Asio Guard 2” help with this issue, with a multicore support improvement?

I want to be able to have more VST plug-ins open whilst mixing, without having to bounce audio, hence the ask for help. With Thanks.

My Computer:
MAINBOARD: Gigabyte X58 motherboard UD5 (July 2009)
CPU: Intel Core i7 2.66GHz QUAD CORE (8 threads HT)
RAM: OCZ Gold Series PC3 12800 1600MHz 8-8-8 RAM (2Gig x 6 = 12 gig) - Recently changed
OS: Window 7 Home Premium 64 bit
HDD: The Operating System W7 & my Cubase Audio are both on separate SSD’s (120Gig & 240gig)
HDD: 2TB Western Digital Standard drive (contains samples & old projects)
GPU: ATI Radeon HD 3450
COOLING: 120mm CPU cooler and exhaust fan, Scythe coolers
PSU: 650W Quiet Modular PSU Seasonic OEM partner

My Soundcard
Lynx AES16 PCI Card connected to a Mytek 8x192 ADDA rackmounted soundcard.


What is your power settings in the control pannel ? Balanced or high performance ?

Thanks mbr, it’s on “High Performance”.

Try the following but be carefull:

Go to Task Manager / Processes / when cubase is runnung what is the average Kernel Value under ( memory ) ? Right click on cubase / go to set priority / What does it say ? set to high ! and also right click and check "sett affinity to : all prosessors and make sure all 8 is ticked.

You have a powerfull system (as mine) although I have much more RAM

Make a new dummy project open for this:
Do the following test. take a project with say 10 tracks ( stereo audio ) and dublicate them a few times to get say 80 to 100 tracks, then go to pool and convert them to say 96 khz and 32 bit float > check now if your kernel value goes up while cubase is converting ?

Thanks mbr

On opening Cubase, with no project loaded,
1.17GB Memory being used, 1% of CPU, Kernal: Paged 158, 26 Non Paged

Right Click Cubase
Priority was already set to “High”
Affinitiy already set to all CPU’s

Created a project with 10 tracks and duplicated them 10 times, 100 tracks
1.39 GB Memory being used, 1% of CPU, Kernal: Paged 161, 27 Non Paged

I went into pool and converted them, CPU went up to 13% as processing them, paged didn’t move, then went to Paged 159, Non Paged 27.


Is this ok? See attached, my Virtual Memory option, j

Can anyone help? I am not getting decent performance from Cubase. It’s running at 70% of CPU in Cubase, when the demands on the actual computer is less than 20% (in Task Manager). I’ve just upgraded to 12GB of RAM (6 x 2GB), no difference.

Can anyone suggest how I can fix this, so I can get Cubase using all the CPU available to it?

I flag to “Automatically…” without issues with memory or cpu.
(Win 7 Ultimate 64 bit with Aero on).

Thanks Lordadb for your response.
Can you explain more, I don’t know what you mean when you say, “I flag to “Automatically…” without issues with memory or cpu.”

Look at your image. You set “custom size” for the virtual memory. Try to set on “Automatically manage paging file size”. And set in “background services” in your “Advanced” section as you can see in my pic (in italian, but you can understand the same).
Give it a chance. :neutral_face:

Ah, thanks Lordadb. No performance change unfortunately, after change & reboot, though THANKS for helping. :smiley:

I appreciate it! I have attached the new options as suggested, with performance of Cubase,


Ok, try these and let me know:

  • Switch to Aero Desktop (cubase 7 and 8 are Aero-based, so you can improve performance working in its right environment rather then the Win98 style).

  • Install (or repair installation) again Cubase. :confused:

Could be shy, but… Try. :slight_smile:

To add, I ran “DPC Latency Checker” - Seems to be working fine, see attached

Thanks for the suggestion, I’ll have a look into Aero and change it over, see if there’s any performance differences

No improvement… So, switch to Aero.

Did you get this resolved?

Hi Did anyone ever solve this. Its identical to my problem now.