Getting double sound from the microphone with UR-RT2

I have Cubase Aritst 9.5 alongside a UR-RT2.
When I turn on the microphone monitor (in order to record vocals with reverb) I get a chorus like sound, because sound is already coming to the headphones from the microphone even before I turn the monitor on. How can I hear sound from the microphone ONLY from the cubase monitor? Do I have to change setting at the UR-RT2 dsp Mix Fx panel?
My microphone is the Sennheiser mk4 condenser.
Thank you!

I am not sure, I bought an UR-RT4 but I am waiting that it arrives. From pre reading the manual I can maybe figure out and guess the sound you get before activating monitoring comes from loopback. Then, when you activate monitoring you get added the actual monitoring of the mic. Check if you have the loopback activated and turn it off if so.

Remember too that for zero latency monitoring you must activate under Studio the Direct Monitoring option. So you will hear the signal from the DSP processing in the interface, instead of returning it from Cubase.

direct monitor did the trick!
Nevertheless, I could no longer hear the reverb coming through the monitor.

By de-selecting direct monitor again I got the behavior I want.

If Direct Monitoring in Studio settings was de-selected, monitoring was off (little speaker on channel) and loopback function was off, then I really don’t understand why you could hear the microphone before. But it is good that this comes no more.

Regarding software/hardware monitoring: in general, if you set up a relative low number of samples you can work with software monitoring regardless latency, for example playing guitar. But the problem with vocals is that, as you hear your own “real” voice and the software monitored, you hear a light double effect, even if the latency if very low and this is for most uncomfortable. That is the reason direct monitoring is preferred in this case.

But by activating direct monitoring in Studio you lose the reverb that I guess you have as insert in the audio channel. Regarding reverb, you have two ways if working with direct monitoring:

-first, your card has an integrated reverb FX (rev-X) thought exactly just for direct monitoring purposes and you can send signal from your incoming channel to it (using the channel hardware controls in Cubase or using dspMixFX if using another DAW) and set up the return level. So you can direct monitoring your voice AND hear reverb. This rev-X can’t be printed in the recording and runs in the hardware thanks the DSP in the UR.

-second, if you have a very special reverb within Cubase, that you want to use and must be this and not another (or you have other effects that you want to monitor too) I guess those will not be heard if direct monitoring is active, as you could note. But I think (and here I am not sure, as I can’t test it yet but want to do it when I get the UR) if you use an FX channel with your reverb inserted and then send signal to it from the incoming channel should work.

Unfortunetaly, the unwanted behavior is back. Whenever I trigger on the +48v phantom power of the microphone I can hear sound being clearly monitored through my headphones, regardless if I have checked the “direct monitoring” box or not. I don’t get it. Also, I did not change any setting. So, why did it work alright for a few days and now it’s faulty again?

To whom it may concern:
The answer lies in the UR-RT2 dsp Mix Fx panel.
I turned down the microphone volume and that killed direct monitoring inside cubase for sure!