Glitch nightmare despite investing in a (supposed) all singing-and-dancing system

Despite having what should be a great system (AMD Ryzen 9 5950X 16-Core Processor 3.40 GHz with 128Gb RAM), I keep getting performance issues with maxed out performance meters, peaks from nowhere, audible glitches …and all of this can suddenly happen without much warning. One day, a work-in-progress is going well, the next I’m in glitch hell.

Quick background: Having been ill for many years and away from my music, I returned to my first love and went 100% ‘In-The-Box’, investing in a decent system that could do both my music projects and video work.

However, before too long I was getting performance peaks that ruined the writing/production experience…

(Just to be clear, this is for music projects only, no video is involved .i.e. my systems resources are dedicated to my music production and not drained elsewhere)

I know I can ‘render in place’ or freeze tracks, but surely the spec of my system would allow me to write a whole piece without having to resort too quickly to such things…?

But hey, maybe I was simply being too ambitious with MIDI and VST tracks, so I saved up and invested in Vienna Ensemble Pro. Initially, I had one license and ran it on the same machine and yes, performance improved …kinda. But as I got more into it, I quickly hit this same maxing out… so I bought another license for VEP and put it on my laptop, sharing VST effects and instruments between the two.

And yet, here I am today with a project that has once again suddenly glitched into the depths of hell despite working fine for a while.

My investigations have had me remove plugins, strip back projects track by track and still I get glitches. This time with one weird difference… the random audio glitches can be heard but the performance meters stay around 50-60% …and the glitches can even be heard in the quiet part of the song when few tracks are playing.

So… Have I managed to invest in a system that is incompatible with Cubase? Am I expecting too much of Cubase to run a good number of MIDI/VST tracks without having to render in place? Should my template file sit at 50%+ on the performance meter before I have even entered a single note?

Please help - I’m pulling out what little hair I have left on my head and might have to resort to my armpits next!

Thanks in advance :slight_smile:

Most likely this is a misconfiguration in a not so obvious area.
I bet it has nothing to do with Cubase itself.

Main board? Audio hardware? Are there tools for the main board installed?
SSD? What kind of? Windows patch level? Additional installed software?

Thanks for the reply… I too have wondered that but wouldn’t know where to start. As for the remaining parts of the system, ASUS X570 Taichi motherboard, NVMe M2 drives (C: drive and VST drive)., two Samsung SSD 850 PRO drives (in RAID 0) for project drive, SSL 2+ audio interface, Windows 10 PRO (up-to-date on releases).

Did you install the ASUS bloatware?
That would be the first thing to check.

Graphics card?

Do you use the AMD software to maintain the system drivers?
What does it show? Is everything up to date?
Try to avoid Microsoft drivers for system relevant parts.

ASUS bloatware… A quick check shows I have ASSRGBLED and A-Tuning installed. Never used either, just ran A-Tuning …Anything specific I should be looking for?

Graphics card: NVIDIA GeForce RTX 2080Ti with four monitors (I originally had the large monitor setup for video work, but its definitely handy when doing my music).

AMD system drivers: I don’t seem to have AMD driver software for maintenance. I use Driver Easy Pro to keep most things up to date. All AMD stuff is 100% current.

Try to avoid Microsoft drivers for system relevant parts.

Not sure what you mean? Can you expand?

Thanks again for your suggestions - much appreciated!

Just this minute this came up…

1 Like

Interesting! So that suggests I uninstall any ASUS software on my system…?

Quick observation: Yes, I have ASSRGBLED and A-Tuning installed but I’m not seeing any references to either in Processes or Services in Task Manager. Nothing in System Tray either. Wouldn’t that suggest they’re not running?

As a “full-blown cover all eventualities” option, I’ve started the process of upgrading to Win11 too.

Thanks again for your help @st10ss :slight_smile:

Oh no, that will introduce new problems. Don’t do it, if you didn’t solve your current problems.

Can you provide screenshots? I had problems with all kinds of mainboard software in the past.
From ASUS, Gigabyte and ASrock.

I’ve recently had issues with an apparently bad graphics driver from AMD. Updating to the very latest version fixed it for me.

And while I was researching that problem, I bumped into threads on various tech forums suggesting to uninstall any special purpose gaming related AMD graphics software, since it can lead to weird latency spikes in a variety of non-gaming software.

Gaming “optimization” bloatware seems notorious for causing latency spikes even in high powered CPUs.

And it’s those CPU latency spikes, which are a frequent source of audio crackles or glitches, even when the CPU isn’t very busy.

He is using Nvidia.

1 Like

Graphics: Yep, it’s Nvidia - thanks for chiming in though. Good point about the graphics bloatware, glad to say got rid of all the Nvidia stuff and the drivers are up to date.

Windows: Have only done the prep for Win11 upgrade (changed boot drive from MBR to GPT and switched on UEFI secure boot). So can easily pause on that idea! :smiley:

Screenshots: Away from my PC at the moment, can get those tomorrow. Do you want to see full list of Services and Processes?

BTW - Meant to say earlier that the buffer size is at 1024. Lower of course makes the problem worse, and even though there’s a 2048 option, it is actually a lot worse if I try that.

Thanks again

Sorry, I totally missed that.

When I still ran NVidia graphics, I also sometimes encountered latency issues even with low CPU usage.

One weird setting with Nvidia that seemed to make a difference for me with latency spikes on my prior system, was related to 3D performance in the Nvidia GPU control panel. Unfortunately I don’t quite remember what exactly that setting was called.

I think Nvidia fixed this problem some time ago, but to use the Game ready drivers could be a problem.
Nvidia is offering so-called Studio drivers, these are made for workstation use.
It is highly recommended to use these on a DAW.

1 Like

Yep, because of my video work that’s what I’ve always used.

@st10ss Just checking, do you want screenshots of Processes and Services?

I hope, I didn’t miss that in this thread, but have you ever tried to run the latencymon utility, to maybe get a hint what process might be causing the CPU hiccups?

1 Like

Yes, to run Latencymon is indeed a good idea. And nVidia drivers were common source of latency issues (I have suffered it myself). I don’t know if that is valid nowadays, but it can be worth checking it out.

Thanks @Nico5 and @Knopf …pretty sure I’ve checked this before. but running again now. Back with result later.

LatencyMon has been running for an hour. Just left PC on, no DAW. This result was unexpected!

All thoughts/suggestions welcome

Running test again because somehow (i.e. I didn’t make the change) the Power Management was on ‘Balanced’ rather than ‘High Performance’.