Global bar number change

Hello, when I try to apply bar number change, it adds me a local time signature to the staff, where I changed bar number. And I can’t have a big time signature in this bar.
How can I apply global bar number change, for all instruments, to keep the big time signature?

Double check that you don’t already have local time signatures going on. I’ve just double-checked this in one of the Dorico Example Projects, and what you’re describing is abnormal behaviour. It should be as simple as selecting a global time signature (or any note in the following bar), right-clicking, going Bar Numbers > Bar Number Change and setting what you want.

Dear pianoleo. You are right, that this is the problem of my project, because others are fine. But I don’t have local time signatures there.
This is my page before bar change:


This is after:

This is the first page of my project. As You can see, the bar number changed at the top of the system, but it don’t affect real bar numbers which You can see in every bar.
Unfortunetely I can’t attach full project here on the forum. And when I deleted rest of the pages (to attache here only my first page), it behaves normally. So the problem could be on the following pages, which also affects backwards.

Was this a MusicXML import? If so, you might find that you actually have hidden local time signatures on many (all?) barlines, which you need to remove…

No, this wasn’t musicXML import.
But anyway, if I am not mistaken, big time signatures are impossible, when there is a local time signature, so how can it be like You are saying? Is it possible?

Very strange thing is, that bar number change adds a number on the top of the system, but don’t change real bar numbers, which you can see, when you click: Viewt–Bar numbers

You’re right, of course. What happens if you delete all the music and just leave the structure in place? Does that give you a project that still exhibits the problem, that you could then upload here?

Yes, the project still exhibits the problem.

Edit. After the advise of Derrek (thank you), now the file has good size to attach here. (before it was too large).
Bar numbers.dorico.zip (748 KB)

If you deleted all the notes, setting the Playback Template to Silence may vastly lessen the size of the sample project and make it easier to transport.

For whatever reason, if you add a Bar Number Change to the barline itself, Dorico adds an independent time signature. I seem to recall this is expected behaviour, at least for the time being.
If, on the other hand, you add a note to bar 4, on any stave except the top one, then add a Bar Number Change with that note selected, the bar number changes and the time signature remains global. You can then delete that note.

Thank you, I’ve tried Your advise and it works once and once it doesn’t. It depends on the instrument and bar I try. So there must be something else. Or I didn’t understand Your method.

Where is it working, and where isn’t it?

I’ve checked winds in bar nr 4 and I could make a global bar number change in:
– oboi
– fagotti
I can’t do it to the rest of the winds. And I don’t need to create a note, it just works with oboi and fagotti.
So, this is the solution. When I will need a bar number change, I will change it in oboi or fagotti.
Still I don’t know why this is happening, but now I can work with my score.
Thank You, pianoleo, for help.