Global Input Transformer problem

My keyboard (Studiologic VMK) is failing and has started to send out a lot of controller 10 events (pan).
I thought the Project Input Transformer could take care of blocking them, but it doesn’t seem to work with this setting:

What am I doing wrong ? :thinking:

Hi,

Instead of MIDI Controller Value, use MIDI Controller Number, please.

1 Like

Hi Martin,
do you mean like this ?

Doesn’t work - CC10 is still coming through…

Hi,

Yes, this seems to be correct, now.

Is the Input Transform applied on the given MIDI/Instrument track, please?

No. It’s the Project input transformer. As I understand it, it should work on every track,
But maybe I’m wrong ?

Hi,

The manual would confirm your way of understanding. But try to apply it on the given track, please.

Yes, this works as expected.
But the Project input transformer seems to be broken.

It seems either the manual is wrong or Project Input Transformer is.
The transformer does not behave as the manual states.
Maybe worth reporting to Steinberg?

Where you can really filter midi before it enters the project:
Open the Preferences in the Edit menu, MIDI → MIDI Filter

grafik
In the Controller section, put it the value on CC 10 and then click the Add button.

1 Like

Hi,

Agree. I don’t remember, it would ever work for the whole project.

I will report this to Steinberg.

1 Like

Hi,

I understand the Project Input Transformer meaning, now. It’s like a global “preset” for the whole project. You have to enable it at every single track, but you don’t have to define it for every single track individually.

If you want to use an individual Input Transformer on a track, use the Track Input Transformer.

BRILLIANT!
Thank’s :slight_smile:

1 Like

Yes, this is how it works.
However, the passage in the manual…

…omits the fact that it needs to be selected on each track individually. IMO this paragraph should be re-written by the manual personnel to describe the usage more clearly.

2 Likes

Hi,

I informed the manual department.

4 Likes