Grand Staff: Bass Clef To Treble

To move notes from bass clef to treble clef system there are the key commands “n” and “m”. It works but the stem it’s still connected to the lower system. How do I get the notes into the first treble clef stem up voice? I tried all voice changing menu items but all of them create new voices (stem down in treble etc).

The piano is improted via MusicXML.

3 - To Here.png
2 - Not Like This.png
1 - From Here.png
Thanks :slight_smile:

alt-n/m might be what your looking for (maybe even with shift?)
Or in case I created this shortcut myself: move to staff above/below in the edit menu

Oh yes, alt-n/m works! I tried some combinations with alt/shift/cmd but one of them opend up new files so the results were buried by overlapping windows…

Thanks a lot!

I’ve often found that XML imports may create two individual single-staff pianos rather than one grand staff instrument. I usually add a new piano, copy/paste the initial one onto the new piano (do each staff individually, not at the same time), and delete the initial instrument(s).

Good idea!

You may also find that explicit clefs are added to your score when importing XML files. If you can click on the clef (it turns orange), it is explicit. Delete all of those at the beginning of the score. I also do a to the SAME instrument in Setup for every player (even if it’s been correctly identified). That attaches any specific quirks about that particular instrument correctly (notes out of range, dynamics above staff [vocal staves], etc).

I also find it’s a helpful to [Write|Edit menu]:
+Select All
+Reset Appearance
+Reset Position
+Beaming|Reset Beaming
+Stems|Remove Forced Stems

This gets everything back to Dorico defaults, so that changes made in the Engraving and Notation Options will be accurately reflected in your score.

You may find otherwise, but these things help me save time overall with XML imports.