Graphics issues in Cubase 10

Hi everyone,

I’m experience some very annoying and frustrating graphics issues Cubase 10 (see attached). Often, when I’m scrolling or zooming, the interface goes ‘choppy’ (the only way I can think of describing it) and shows stuff that isn’t actually there (e.g. sometimes if I change the name of the track, nothing happens in the GUI until I pass my mouse over it - then it updates). The screenshots don’t do it justice (it decided to not be too bad tonight), but there are times when it’s almost unusable since it’s so choppy.

I’ve googled it and a lot of people seem to say that uninstalling/reinstalling the graphics driver solved it, but I’ve tried that both with the Nvidia gaming drivers and the Nvdia studio drivers, with no effect. I also tried starting Cubase using the integrated drivers rather than the dedicated but the issue persisted.

For reference, here’s the hardware I’m using:

MSI GF75 Thin 9SC
i7 9750H
16GB RAM
Nvidia GTX 1650


Hi,

Please try this:

  • Uninstall the NVIDIA driver.
  • Download the latest Studio driver version from here.
  • Start the installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settins.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), keep just the video driver enabled.

I’ve got similar issues and nothing is helping, I just keep getting told to uninstall my graphics drivers. I even recorded a video of it, can’t believe I burned $60 for this update.

Martin thanks for the info, but that still didn’t fix the issue.

I’ve been told multiple times to uninstall then reinstall the drivers, but it never works. This is starting to hinder my work - I paid around £170 to upgrade to Cubase 10 and I’m starting to wonder why I did…

Hoping that someone else out there has managed to fix this problem.

Not that it’s any help, but I have the same graphical issue as James, this with Cubase 10.5 and Mac Catalina. I don’t know if it’s the upgrade from Cubase 10 to 10.5 or the Mac upgrade from Mojave to Catalina as foolishly I did both at the same time, but needless to say I didn’t have these graphic glitches under Cubase 10 / Mojave. So if anyone works out how to fix it, please do tell although probably a fix is required by Steinberg or Apple.

Micky

Yep…same issue here for quite a long time. That is, upon zooming into a waveform, the audio editor become extremely jittery/jumpy and the waveform seems to “float” while trying to find the exact point at which to make an edit. Really unusable after a certain zoom level.

I’ve tried every fix suggested by tech support : Uninstall the Nvidia driver. Use only the windows driver, update the Nvidia driver, nothing helps at all.

fwiw, I’m on Windows 10 Home 1909. Cubase 10.5.12 Pro. RME Babyface Pro.

The Cubase 9.5.50 GUI is also UNUSABLY slow for me with an NVIDIA GeForce 210 graphics card using driver version 342.01, whether a busy project or a completely empty one is loaded. On the other hand, 9.0.30 works just fine with my same hardware/software setup. I was just about to upgrade to 10.5, but I’ll be holding off until I get an answer on this…

Hi,

If you have NVIDIA, try this, please:

  • Uninstall the NVIDIA driver.
  • Download the latest Studio driver version from here.
  • Start the installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settins.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), keep just the video driver enabled.

I have the same computerspecs and 1,5 years ago I bought the same GForce210 to work with 3 screens(1 still on my MB graphiccard).
Nothing but troubles with Cubase: spikes, dropouts, slow etc.
I switched the card for a simple cheap Radeon R5230 and everything turned out perfect. W10+Cubase10.5 works almost troublefree and smooth.

Although in your case it’s not good to have this issue, it is good to know that AMD and Nvidia “seem” to have issues. I air quoting “seem” because if I ever an issue with Cubase I keep getting told it’s my AMD 5700xt drivers even though I had similar issues with a GTX 1060. My issues were and still is, Cubase randomly freezes for a couple of seconds and then crashes to desktop and the other is Cubase not closing properly so I have to go into task manager and stop it. Could both manufactures have poor support or is Steinberg not updating Cubase to work with certain cards?

PROBLEM (THOUGH PLUGIN GUI IS FINE)

SOLUTION

RESULT

A thing of beauty indeed…

Relief. I hope this helps other people.

1 Like

what exactly did you turn off? only what is pictured? or everything in the list?

I just went down the whole list turning everything off that I could until things were cured.
Sorry, I was totally unscientific about it. Haven’t had time to test what exactly did the trick. THese images show all the settings:
NV1
NV2
NV3

1 Like