graphics2d.dll crashes

Not going that way, sorry. Drivers have to be up-to-date. I’m not looking for a temporary fix, I’m looking for a solution in which Cubase 11 pro can coexist with an up-to-date system for the next year or so. And driver updates are going to be needed soon or later on this system (Cubase is not my only production application on it).

I’m ok using the latest nVidia studio drivers though, since it’s designed to be the most reliable and stable version of the driver.

@wildschwein No need to delete you answer mate! It wasn’t a bad idea. I did try 2 other versions of the studio drivers, and I was still having crashes. I don’t think the problem is there.

Also, I wanted to add that I tried yesterday evening to completely uninstall all versions of Cubase, and only reinstall 10.5.30, which never crashed since its release in March, and now it crashes the same way as Cubase 11…

Somehow, Cubase 11 installation corrupted my system (or saved faulty data in the registry), and now I can’t run any version of Cubase without experiencing random crashes all the time (linked to the dll mentioned in this thread).

I keep updating my ticket, but so far received no answer.

Any thought?

1 Like

Hi,

Can you restore your system back to the point before Cubase 10.5 and Cubase 11 installation?

That’s a good point. I should have done that when I saw 10.5 was crashing too.

Anyway, currently trying things with Steinberg support, so we’ll see how it goes.

Still having problem with this one. Is the a new “version-upgrade” on the way soon?
Cubase 11.0.30.419 64bit 2021.8.22 17.42.48.940.dmp (548.4 KB)

Hi Fredrik,

I was having this problem recently too, and what I have done so far that seems to have fixed it is:

  • Reinstalled Cubase 11
  • Gave full permission rights to the graphics2d.dll file on my user account (I noticed admin account had full permission but not my standard Windows user account)
  • Created an exception for the file in Windows Defender (and worth doing in any antivirus you use)

So far after a week I haven’t had any issues.

Did all your sugestions simonslee .Still an issue for me though. graphics2d.dll is still a problem. Anyone else?

1 Like

Same for me, it’s still happening, and mostly when editing MIDI. I remember having a MIDI editing issue years ago on earlier Cubase versions but this seems different.

I’ve ordered a new video card and will try that when it arrives, I don’t know what else to do, nothing works.

I really hope Cubase 12 fixes the problem.

1 Like

How exactly were you able to give permission rights to the graphics2d dll file?

I’m definitely having this issue as well. Trying everything that is recommended.

I just right clicked on the file, go to ‘properties’, choose the ‘security’ tab, click ‘advanced’, and then in the ‘permissions’ you can see the difference between your current user (which might have read only access) and the admin account (which usually has full control). I set the file to have full control for the user account.

It didn’t make any difference for me in the end, but this is how I did it.

same issue here in 2022 using Nvidea GeForce 710 card, no studio driver but I’m using Nuendo not Cubase

Hi,

Please try this:

  • Download the latest Studio driver version from here. If there is no Studio driver for your graphic card, use the one, which is available and continue with the same steps bellow.
  • Disconnect the computer from Internet to make sure Windows will not download and install own graphic driver.
  • Uninstall the NVIDIA driver.
  • Restart computer.
  • Start the NVIDIA driver installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settings.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), keep just the video driver enabled.
  • Connect your computer to the internet.

C.11.0.41 and GeForce 720 card here - no crashes.
Latest drivers installed

regards

Hi I did this, but I’m still getting the same issue
What’s happening now is that it seems the computer hangs for a second and everything freezes.
If I click with my mouse or try and execute a key command on the keyboard while it’s hanging or just a moment after it crashes and gives me this error.
this seems to only happen in Nuendo though so I don’t think it’s hardware related.

Hi,

Could you share a DMP file, please?

sure here’s the latest DMP file
Nuendo 11.0.41.448 64bit 2022.2.1 13.28.26.171.dmp (1.0 MB)

Hello!

here is the dump analysis result:

PROCESS_NAME: Nuendo11.exe
ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.
SYMBOL_NAME: graphics2d!createGraphicsFactory+31a0e
MODULE_NAME: graphics2d
IMAGE_NAME: graphics2d.dll
FAILURE_BUCKET_ID: NULL_POINTER_WRITE_c0000005_graphics2d.dll!createGraphicsFactory
FAILURE_ID_HASH: {6a5580b9-7e24-1a41-f26a-af7044797d35}
Followup: MachineOwner

you should try this (in command line):
sfc /scannow

regards

Hi,

Reported to Steinberg. Thank you.

I had the same crashes with AMD Ryzen 2400g with integrated graphics. And Cubase told me graphics2d and ucrtbase. But what really happend had nothing to do with it. It was a samplerate clock issue between Interface and ADAT-Device.

Since i found it, i never had graphics2d and ucrtbase again and no random crashes! This was over a year ago - no problems since then. Still same CPU / GPU / Hardware etc.

1 Like