graphics2d.dll crashes

Hi and welcome on the forum,

Could you please attach a *.dmp file?

Mac: macOS Console utility > User Reports folder or Crash Reports in macOS 10.15 (or ~user/Library/Logs/Diagnostic Reports).
Win: Documents/Steinberg/Crash Dumps

Cubase 11.0.10.321 64bit 2021.4.17 13.01.41.189.dmp (517.7 KB)

I’ve got similar problems too. Buying a new Nvidia GTX 1650 doesn’t work as well. Latest drivers, bios and motherboard updated, . NET reinstall etc… Nothing seems to work. I’m gonna try the “ownership” trick tomorrow. Fingers crossed.

Btw, using a Ryzen 9 3900 (if it matters)

Hi,

Please, update to the latest Cubase 11.0.20. If it’s still crashing, upload Cubase 11.0.20 dmp file, please.

Please try this:

  • Uninstall the NVIDIA driver.
  • Download the latest Studio driver version from here.
  • Start the installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settings.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), keep just the video driver enabled.

Thanks Martin, I’ve just tried it, still the same graphics2d and ucr ucrtbase.dll issues.
Also, the “ownership” trick, but it didn’t do anything.

Seems hopeless. Any other suggestions?

Update:
I’ve just uninstalled all the newest Nvidia Drivers, tried Cubase on the standard Windows Basic-Display Driver. Works just fine on one screen. Maybe it’s a workaround for some of you guys, but unfortunately I’m using two screens, and Windows Basic-Display Driver doesn’t support two screens.

Good news here, it seems like I’ve found a solution that works for me.
Please try:

  • 1: Download ‘Display Driver Uninstaller’ (DDU): here
  • 2: Extract/unzip the files
  • 3: Start your PC in Safe mode:
    -Win + R (on keyboard)
    -Type ‘msconfig’
    -Check ‘safe mode’ in the second tab
  • 4: After rebooting your PC, open 'Display Driver Uninsteller.exe
  • 5: On the right side, select:
    -Device: GPU
    -Select your videocard manufacture (‘NVIDIA’ in my case)
  • 6: Go to options (left corner) and make sure you’ve checked:
    -Prevent downloads of drivers from “Windows update”
    -(NVIDIA) Remove all specific options
  • 7: Click on “Clean and restart”
  • 8: After rebooting your PC, go to: here
  • 9: Download and install the latest STUDIO driver from NVIDIA, like Martin said, make sure to ONLY install the Driver, not the other options.
  • 10: Enjoy

Cheers

1 Like

Update: I have 2 identical computers (exept for the graphics card), one with nvidia GT 610, the other one with Nividia - 8500 GT
The Nividia - 8500 GT was still giving me problems with cubase.
Replaced it with a Nvidia - GT630 (laying around). Problems solved.
I am aware of the fact that these are both quite old cards, but I need dual VGA.
As mentioned above, only install the driver and do a clean install.

Just to let you know that the Nvidia GT 600 range works here…

Hello, i had similar fatal error issues with my radeon drivers (RX 560). I did solve with using the above DDU instructions. But there are new radeon drivers that are windows 10 signed that just came out and they now allow for just driver install again (finally!). It seems to be working well here. The radeon drivers seemed to go to crap about 10 months ago. Hopefully things go smoothy again.

I have had exactly the same problem with repeated crashes. I have a GTX 770 card and never experienced any problem with previous versions of Cubase. As there seems to be many people having the same issue, I think Cubase needs to look into this as these cards are not too old and cubase is not a 3D video game. Cubase technicians need to contact Nvidia technicians - identify the issue and do new updates. It is not rocket science.

There is no studio driver for my card either (studio drivers are quite recent).

Something I discovered which might help is to disable HDPI settings in preferences.
After I updated to the latest Geforce driver and disabled this, I have not had a crash.

The problem is that for many cards, there is no studio driver.

Hi! I’ve just installed Cubase Pro 11 on my laptop and starting to have this crash. Tried almos all the suggestions, but non of them worked. After a while trying different things I started to see a pattern, and that involved the use of the laptop screen with the mixer. If I leave all the windows on my external screen, connected via HDMI, all worked fine, but the minute I moved something to the internal screen, the crash happened. So I blame it on the dual graphics card configuration (I have a Deel XPS with both Intel HD3000 and NVIDIA GT525m) and the swap between both cards, as the HDMI monitor is connected directly to the NVIDIA, and the internal is to the Intel. So on the NVIDIA configuration panel I selected the internal graphic card to do all the Cubase processing, and since then everything seems to work fine. Using both monitors right now and finally doing some recordings.
Hope this helps, Best regads

1 Like