Grid/quantize not working in midi editor

Hey the grid in the midi editor doesn’t seem to be working for me.

https://youtu.be/JGWpQoVV2eQ

It seems to be stuck on a sort of “adapt to view” kind of mode. The grid won’t change along with the quantize grid length… but it will change when i zoom in and out…

also, I have no clue what it’s doing when i hit quantize:

https://youtu.be/IlmY_34LUUQ


specs: windows 10, i7-5820k with 32gb ram

Oh WAIT. nevermind… i just noticed each “beat” was being sub divided by 5 despite me not having it set that way… and then I realized that the grid was set to “seconds” instead of “bars+beats”… kinda feels weird for the midi editor to be set to that by default though… lol… anyway, seems like i got it worked out!

Hello, how did you solved it? where do you change from seconds to bars and beats? thanks

I just had to right click on the actual ruler on the top of the grid and select “beats+bars”. I think this was right after I had updated/upgraded and for some reason by default it was set to “seconds”. I don’t think I’ve ever had the need to set my midi editor to seconds (although it is nice having the option), so I’ve never really thought to check that. But yeah, that’s all it was.