Grid snap ignored in Editor

I VERY frequently set the left and right locators in the Editor with CTRL and ALT key and click on the time ruler. But unlike the project window, the editor ignores SNAP settings in favor of following quantization settings only, which makes selecting time ranges MUCH more difficult.

Please fix the editor to follow SNAP settings when selecting time ranges or setting locators.