Groove Agent 4 Missing Kits, Patterns & General Mess

Hi - with a GA sale on, I decided to buy two new add-ons. Installing these seemed to have made GA forget about my other kits and add-ons. I’ve had similar problems before, leading me to think that the software can get in a mess pretty easily.

However, I wiped my machine and reinstalled Windows 10 Home from scratch, and I’m looking for installation pitfalls, and ways to fix them without a reformat. I’ve been trying several combinations - each with a clean windows install -and so far nothing has seemed to work.


  • Windows 10 Home PC
    OS on M.2 Drive, apps on SSD
    Make sure Windows configured and up to date, with e-licenser installed
    Installed latest Cubase 9.5
    Installed GA4
    Typically I install for any user to use, but I suspect this may be part of the problem, so have been experimenting with both
    I only change install paths of apps (to ssd drive), I don’t touch appdata (should I?)
    Reboot between installs (and click update library icon in GA and wait where appropriate)

Addons I’m trying to install - Blues Essentials, Rock and Roll Essentials (existing ones), Nashville, Simon Phillips (new ones)

Problems experienced at various times (all by right clicking on slot and selecting “load kit with patterns”…

  • Only SE Kit available - all others gone
    Blues and Rock and Roll not available after installing
    Blues & Rock and roll available, but will not load when pattern clicked on
    installing Nashville & SP makes all other kits disappear (plus missing sounds warning with metronome and another file)
    Possibly others and will add


  • Why does the installer for addins offer to install for any user? Surely this should adhere to the host app’s settings
    I think it’s getting confused about where kits and patterns are, is there any way I can make sure all files are in correct place?
    Is there any log file? When failing to load a pattern it would help if I could find what and where
    Would it improve things if I manually set a location for the appdata for everything?

Like I say, there needs to be a way to fix this post install, since it doesn’t seem robust enough to work out of the box. Apologies for the long post, but I’ve been putting a bit of time in over the weekend…

Make sure that you’re also installing the latest Groove Agent 4 update.

Thanks - I’m pretty sure I’m using the latest GA installer from the website, but downloading again just in case (hard to tell, since I can’t find full version info in any of the files). Prefer full install on a clean machine.

You can download the latest updates for Groove Agent 4 here:

Groove Agent SE 4:

Thanks - that may have fixed things. Clean install of Windows today. Fresh download of GA and gradual reboots and everything’s on there (I think)

The only problem that I currently now have is in Instrument Editor - with Nashville & Simon Phillips, clicking on an instrument does not make it sound (I don’t have Mute Instrument Trigger on Editor selected). It’s not the end of the world, and I’m not sure whether they’re supposed to trigger on add-on instruments, but it would be handy.
GA4 Kits.PNG
I’ve attached the kits I now have installed on the off-chance that somebody may know if any are missing.

Thanks for your time.

“Fresh” download of GA means stone-old installer. You have to install the updates nevertheless.

How do you do that? The update on the site is the same version as the full download, and I cant find anywhere in the app to check/trigger.

UPDATE: Apologies - had been staring at the GA download page for so long that I didn’t realise the full app was 4.2.0 and the update was 4.2.4.

Clean install, selecting “all users” on main app and add-ins, and all seems to be working as expected now! I’d also noticed that my previous install that I thought was OK was missing some instruments on the Simon Phillips pack - none of the crash cymbals would play.

Thanks for your time guys.

Hi Folks,

A rare visit here for help because I can usually work out any problems by trial & error.

Over the years I have purchased some extra sounds for GA 4 but I still find it overcomplicated to access all the drum sounds. I think it is because some of the content is on different drives. The whole thing could do with a sort out.

The problem is within’ the ‘Load’ window - in the ‘Browser’ section I often get a red ‘unavailable’ icon. My workaround is to move to the ‘Media Browser’ - From there I can usually access the files I’m after.

What I cannot work out is where Groove Agent looks for the ‘content’! I have tried using shortcuts to direct GA to the right files but I’m doing something wrong. Is there a tutorial I have missed somewhere?

If I go to… C/ Users/ My computer/Appdata/ Roaming/ Steinberg/ Content … I have folders ‘VST Sound’ and 'Groove Agent/VST Sound. Both have content. However I also have content on at least 2 other drives. I’m reluctant to move anything in case I muck up the files for Cubase, hence using shortcuts.

I would be so grateful if some kind soul could at least point me in the right direction. (I’m 64 this year but I think the old grey matter is still working!!)

Best wishes


I’d be interested in this as well, since I’ve had patterns not loading, samples not firing, and things just plain not there. I wouldn’t really mind where it kept things if it “just worked” (as long as it wasn’t filling up my system drive), but that doesn’t always seem to be the case. And without much to go on in terms of diagnosing if/when it does fall apart, a crib sheet would be handy.

Thats the best example to demonstrate the Steinberg download mess…
If I buy the newest Absolute today, do I have to expect a 3 year old GA Installer in my downloads ?

It works for me. Couldn’t load Several Extensions with an alert: It was created for a newer version of a GA.

I make the topic for my problem, but no one answer, so maybe here someone can help:

I purchased Neuro and Prime Cuts sets and I expected they should add some of their patterns in Pattern library. In screenshot you can see that only user and Beat Agent SE patterns are shown.
When I load any of Neuro or Prime kits with patterns - its loaded, but still doesnt show any other of their patterns in library.

I had problem also with kits, which were shown in Mediabay in DAW, but were absent in any of GA options. After I’m uninstalled trials and install GA and extensions in one place by default - they appeared everywhere and it’s seems ok now.
But patterns are absent - as you can see here ((

I use Cubase 9.5.21, GA4, installed last update and Windows 10.

I’d be appreciate for your help!

I had a similar issue (all VST libraries working in GA5 after new PC/fresh installs, etc, except Songwriter Essentials). Tried everything but in the end, this worked for me (damn firewall!!!):


  1. Uninstall VST library from Steinberg Library Manager
  2. Uninstall VST library from PC using Add/Remove Programs
  3. Disable all firewall/virus protection
  4. DL/Unzip/Install library in default folder
  5. Re-enable firewall/virus protection

I have GA 5. I have stopped using Cubase because it is so unreliable and the support is absolutely shocking in Australia. I have been using GA5 successfully in another DAW but now most of the kits are missing (again). Terrible waste of money should have got another drum VST. Sreinberg software is truly awful.

I barely ever have any problems so what are you doing?

Ive also just bought a couple of the vstsound expansions Nashville and Simon Phillips Jazz Drums. Im also using GA5 but I assume as far as paths and content locations is concerned it operates the same as GA4.

I use two individual macs each attached to a single dock which host the dongles and the hard disk where i keep my shared VSTSound library. The first machine turned on gets the dock access. However whilst it lets me run cubase on which ever machine is turned on first, the way that Steinberg has coded the Steinberg librarian means only the machine where the expansion was first installed actually sees the path to any moved VSTSouund library files.

The problem is that when installing VSTSound files on the above Instrument sound packs via the Steinberg installers all the files are targeted to each machines own hard disc and the default locations used for the steinberg content files. Groove agent has its own VST sound library on each machine.

The steinberg software librarian lets you move the original sound files to a new location after install. In my case the shared drive. But the librarian software is also unique to each machine. It operates by moving the sound files and putting in place an alias (mac) or shortcut (pc) in the original location.

This means after installing on one machine and moving the sound files to the new shared location from that machine, the second machine still can not see the vstsound files in the new location despite having the direct physical access to them as it is missing all the alias files required by GA which are auto created by the library software when it moves the files.

Im looking at two possible solutions.

1: Run the installer twice once on each machine. That should create the sound files twice in their correct locations. And run the librarian move files twice. The first will move the original files and create the correct alias on machine one, the second should also create the alias on machine two and I am assuming will attempt to overwrite all the files in the shared library location. (hopefully it doesn’t stop when already encountering the same file but will just overwrite it with the same original file)

2: This is to copy all the alias files from the Groove Agent VSTSound library on machine 1 and place them in the Groove Agent VSTSound library on machine 2. This should allow Groove Agent to see the files and operate but I suspect it will not update the Steinberg librarian leaving the two machines librarian software out of sync.

It a pity the sound librarian can’t be pointed at the shared library on the external hard disk and update itself from the content found.

My current observations might assist some who are trying to fathom the apparent mess which occurs when things can’t be found. Its all these automatically allocated paths by the program designers used bt the differing VST instruments assuming it makes all our lives a little easier without knowing how we really want to manage our storage space.

So Im about to experiment with fingers crossed via using option 1 above and hope I don’t give myself a mess to sort out.

All observations gratefully received.


Well if I contact support, I get none! So nothing.