Groove Agent-Loading paterns to a track

So im watching this video: https://youtu.be/hqAEnUxhyJo
and @2:16 he clicks and drags a patern to the groove agent track. When i do that it doesnt work as it should; it starts playing differnt patterns where it should be playing instruments.

Any thoughts?

Thanks

Same problem! Also, when I’m using two beat agents at the same time it won’t load both of them. I have to drag and drop them separately. The one I drag and drop to the cubase is totally diferent from original beat or it uses just parts of instrument (for example, only kick and hihat). …?

Try this:

  1. Add an instrument track and set up GA.
  2. Now make sure the pattern pads are showing, and click the midi port icon under pad 1 to switch on Use Pattern Midi Ports for Pattern Pads.
  3. Drag a pattern onto the GA track and start playback.
  4. This should play a cacophony of sound.
  5. In the track inspector, change the midi channel to 2 and start playback.
  6. You should now hear the pattern playing back correctly.

However, the manual says to do 1. and 2. above then create a midi track and set its output to Groove Agent - Main. If you do this, you’ll notice that the midi channel changes from 1 to 2.

You can add as many additional midi tracks as you need setting them to Groove Agent - Main for dragged patterns, and Groove Agent - Pattern for triggering patterns. Each time you add a track, the midi channel changes to the next available. Presumably this is being managed internally by Cubase.

I noticed, also, that if you go the additional midi track route, then unless you have selected the GA track (i.e. not the midi track target), then the drag/drop will not work.

Anyway, that might be way off for your problem/s, but hope it helps.

2 Likes

Hello Sergeant Blikey,
Step 2 worked for me and fixed all my problems.
Thanks a Million!!!