Groove Agent only loads one Kit

Hi there. Since I bought Cubase 7 in 2012, the Groove Agent only loads one kit. For All other kits it says that sounds could not be located. I thought this problem would end when I upgrated to Cubase 7.5 but the problem continues.

I am using an iMac 27".
Is there anything I can do to fix it?
Can anyone help me solve this please?? :cry:

I would suggest reinstalling from Complete Installer at That should correct the missing content.

Thanks Chris. I will try it.

Thank you Chris. Your advice worked for me. Installing the ISO file was simple (Windows 8) by double clicking on the files. No DVD disc had to be burnt.


Glad to hear it worked for you!

Windows 8, 10.8, and 10.9 can all read the .iso files directly. For installation on Windows 7, users need to either burn to DVD’s and install, or use a program to read the .iso files. If you do not burn the DVD’s, I would suggest backing up the .iso files to a separate hard drive for future reinstallation.

Hi chris, trouble here. I have download both flies, the Cubase 7.5 full installer and Halion Sonic 2 but the installer is asking me to insert Halion Sonic 2 disc to continue the installation. I couldn´t figure out how to solve this and continue. I have opened the Halion Sonic installation file but it there is no progress. Do I have to burn the downloads on DVD´s??? Or there is a step I am missing???

Is it asking for Halion Sonic 2, or Halion Sonic SE2?

I would suggest downloading both the .iso files for the Complete Installer again. Load the 1st .iso, then load the 2nd .iso. Now install from the 1st .iso that is loaded on the system. If you get an error, please take a screen shot of it (Shift+Command+3).

Chris, it is asking for Halion Sonic SE at the very installation stage as screenshot below shows.
My installation is in portuguese, the official language in my country.

Do you have both “discs” loaded (this is one of the reasons we ask for the full screen shot so we can see what is on the system)? Go to the 2nd .iso and load it. Then are you able to advance the installer? If not, install manually from the 2nd .iso.

Chris, It worked perfectly. All Kits are loading now. Thanks a lot! :smiley:

Glad to hear it, Happy Recording!