Groove Agent Preset Error

Hello, i recently upgraded to Groove Agent 5. Now when I start up Cubase, I get a licensing error stating I don’t have a license for “Beat Agent Presents”. I reran eLicencer maintenance and verified my content. Anyone know what is the issue?

It’s not a big deal as I have tons of other GA content, but just would like to get rid of this error. Beat Agent and other Drums work fine.

Did you download the updated Groove Agent 5 content from the Steinberg Download Assistant?

You can verify by running the Steinberg Library Manager and checking if the new “Raw Power” and “The Kit” libraries are installed.

yes. i downloaded the content using the download assistant. those two items are installed.

do i need to remove GA SE?

You shouldn’t have to, Groove Agent SE’s content is exclusive to it (but it can be loaded by the full version) and the plugin shouldn’t interfere with the full version of Groove Agent 5.

However, I think it’s possible that GA SE is trying to load content from the full version, which is not possible. Try updating to the latest version of GA SE, and if that doesn’t work follow these instructions:

Replacing “HALion Sonic SE_64” with “Groove Agent SE_64”.

This will force the plugin to rescan your content. The same can be done with the Cubase folder if you ever notice other content missing or misbehaving.

Can you take a screenshot of the error message along with the Cubase loading screen if you get this error again?

I tried again. I a still looking around to find that folder. What I notice, the error only appears in Cubase – and not in the standalone Groove Agent application.

I will assume the Groove Agent purchase I activated this week is on the new licensing model? As I don’t see it on my computer on the USB e-licenser at all.

Attached is the error.


The license should be using the new licensing model. Please run the Steinberg Activation Manager to verify that it has been activated correctly.

First, make sure that you’re running the latest version of Groove Agent 5 (5.1.11).

Try this:

  • Close Cubase.
  • Open the Steinberg Library Manager and check where the Factory Content is installed to. By default it’s “C:\ProgramData\Steinberg\Content\VST Sound
  • Go to that folder and leave it open.
  • Back to the Steinberg Library Manager again, to the right of Groove Agent Factory Content, click Remove then Unregister.
  • Start up Cubase. Do you still get the error? Click “remove” if Cubase complains about the files being missing.
  • Close Cubase, switch back to the folder and double click the “FCP_SMT_144_GA_Presets.vstsound” file.

I also am having the exact same issue described. Upgraded to GA5 yesterday, running Cubase 11 Pro and getting the same error code.

I have followed the aforementioned steps and it has not resolved the issue.


Just wondering out loud. Could it be a related issue to the below. The download assistant updated a portion of the Beat Agent libs?

Update on my situation: I spent about an hour doing a remote session with Steinberg Canada controlling my machine and going through the various libraries. Everything is installed & registered correctly. We established that the error was from Cubase and not GA5 because it did not occur when booting the stand along version of GA5. In the end, we speculated that it might have to do with the boot sequence of Cubase version 11 or lower, in that it doesn’t necessarily check the registration status of products on the new licensing system correctly as it boots while using the old licensing system. As a test, we downloaded a trial for Cubase 12 which uses the same new licensing system as GA5. The issue did not occur while booting Cubase 12.

So it appears that it’s a glitch in the boot sequence of Cubase versions that use the old licensing system when trying to load products on the new licensing system. At least not on my end, there is not actual effect on the use of GA5, just an annoyance while booting Cubase 11 Pro. I will use the trial of 12 until it runs out and hope for either an update to 11 or a late summer sale on an upgrade to 12.

Hope this helps.

1 Like

Well, that would explain why the solutions provided in this topic haven’t done anything. I’m sorry for the inconvenience.

1 Like


This is probably an issue caused by the transition from the eLicenser to Steinberg Licensing. Groove Agent 5 is using Steinberg Licensing. And the MediaBay in Cubase 10.5 doesn’t know about Steinberg Licensing and gives you an error.

Do you only get the message for the Beat Agent presets?

1 Like

Yes, and upon booting up, they show up with a red negative sign on the left hand column where there would normally be 2 small squares. Double-clicking seems to kick start the new licensing and the red negative signs change to 2 squares the presets load correctly. It’s an annoyance but no function is lost. There are no issues at all when running Cubase 12 (aka new licensing system).

I am getting the error in Cubase 10.5.x but I ignore it and continue. GA5 works fine. I looked around and can’t really see any functionality lost or red boxes. What are the Beat Agent presets , midi or mix presets or something else?

I believe they are kit presets, but at least for me, nothing was missing and everything worked correctly. Just a glitch in the license checking sequence that generated an error message without producing an actual error.

It looks like an update for the factory library has been made available through the Steinberg Download Assistant. Can you guys check if it gets rid of that error message on start up?

The Beat Agent presets are the basic drum machine/MPC-style presets that were part of the original GA4 factory library. You can use the content set browser to the right to filter for them. There should be 102 presets.

Matthias is asking if you’re getting any other errors besides that one in your screenshot.

No other errors I can see. The GA 5 works fine as does all the drums I have for it.

I usually don’t use Beat Agent so was looking around to see if there were mix presets or some other thing I am missing. I can’t see anything out of the ordinary. Other than that first initial pop up when I launch Cubase.

We have updated the sound archives. Please launch the Steinberg Download Assistant. The new archives will show under “updates”. Please download and register the new archives and the issue should be solved.


I installed the GA content update. That seems to have fixed it. Is there anything else we needed to do after the update? I don’t know if its my imagination, but it seems that kits load slightly slower now.