Groove Agent SE 5.1.0 Missing patterns

Good day!

After installing Cubase 12 I’m missing some patterns in some kits, and the few patterns that are being displayed are obviously playing wrong, they sound like patterns from other kits.
Reinstalling Groove Agent SE and its library (including via Library Manager) didn’t help.

Any ideas?

I have noticed the exact same problem in Cubase 12 Pro. I thought maybe I was not using Groove Agent correctly but then I noticed the same pattern just kept loading even after changing drum kits. I had to revert to using Cubase 11 Pro and then import the track from the project into Cubase 12 Pro. Obviously, this not ideal and really slows down the music creation process. I suspect Grove Agent/Cubase 12 is not looking in the correct folders/drives for pattern content. Would be very interested in a fix for this issue.

1 Like

Thank you!
I tried opening Cubase 10 and the patterns look the same, so unfortunately it didn’t help.

I found in Elements 11 you have to click on the little icon next to the Omni on left bottom so it turns yellow. It has something to do with the midi channel it uses.
I used to find the sample pattern you dragged onto the drum track was not always what would play. It seems to behave itself and work fine since I discovered that trick.

Me too Philip Minogue ; I have 12 as well Pro to be Exact. I have been having the same thing. Also between my Groove Agent & Hallion In the Instruments Box. Between them both . The Instrument Changes you should have otions to. Like All the Special Drum Programs are missing and are mixed up . In my Halion SE 3.0 I had More Drum Program Choices in SE3.0 Than Groove Agent 5. That’s when I knew there was something wrong. Something with the Registry, When Downloaded in I guess. But it is fixed now. But there is still one or two that do not have all the Pads Set up on them, Like the one you showed. I had to get a tech take a look at it. But I think it could be a Registry Problem. Or Cubase made it that way. But I think not. I think it is supposed to be full. Unless it is for Just Hi Hat sounds. Click on the instrument box and see what you should have on there by what you are clicked on at that time. If your only supposed to have just 6-8 not full 16 pads connected. But You can also Assign Pads. There are Video’s on how to do just that on You -Tube. Do a Search in You-Tube asking Cubase 12 Pro Assigning Pads in Groove Agent or Hallion. You will get lots to choose from. Good luch Philip. I hope I helped ya out.

Thanks Mikey for your input. Actually I was wrong saying I could find the missing patterns in Cubase 11 Pro. I have the issue here also. The problem started when I upgraded to Cubase 12 Pro. All the kits and sounds are there but the patterns are all messed up or just missing. So when I change kit/pattern it keeps playing a default pattern which sounds like a mess when you change kits. Before this issue the patterns would play the correct drum sounds for each different pattern, now it doesn’t. I might raise a ticket as they have been helpful before. I had issues upgrading to 12 Pro with loads of VST’s missing but I found a fix for this in the forum. I know I can create my own patterns but having lots of factory patterns helps plus gives you ideas when just working on some ideas for a track. If I find a fix for this I will post back to the group.

1 Like