Group Channel To Selcted Tracks Bug

Please help.
Group Channel to selected tracks creates a group channel but DOES NOT rout the selected tracks to the group. Then I have to manually rout each track to the group. I just upgraded to 13 hoping that would fix the bug but no. Please help!

I you can select all tracks and then using a key command route them all at once. In Windows it’s Shift+Alt I believe. Hold that down and then make the selection. You don’t have to do the tracks one-by-one.

Thanks for the response. I actually tried that as a work around and it is also not working. I don’t get it. It only reroutes the channel I actually make the change to even though I select multiple channels with shift + alt. Only work around is opening mixer and selecting q-link. That allows me to reroute multiple channels at once. But that still adds a bunch of extra clicks to a command I rely on daily.

It’s not when you select multiple channels that you hold down those keys, it’s after you’ve selected the channels.

  1. Select multiple channels any way you like.
  2. In the slot where you select the output, on one of the channels, click once to get it to drop down and show the group channels.
  3. Before clicking on he group channel that you want to output to hold down SHIFT+ALT and while still holding them click on the desired output.

Alternatively you can begin click-holding those two keys before you click on the drop-down menu for destination paths.

1 Like

I sware I am doing that and it is not working. I select a few tracks then hold shift alt and while holding I change the routing to a group, then let go. It only changes the one track.
The bigger issue is that when I add group channel selected tracks. It only creates a group channel and does not reroute the selected tracks. Ugg. This command worked correctly for years and in the past 6 months stopped. Is this not a bug?
Thank you for the help

I just tried it in Nuendo 13.0.2 and it works fine for me.

Are you sure a) all selected tracks are audio/group tracks, and that b) you’re not accidentally “asking for” a routing that would feed back into itself?

yes I am sure. It should work. I suppose I should uninstall and reinstall.

Any chance you can capture a video and share? Just so we can rule out any accidental errors?

It didn’t capture the right click activity for some reason but I selected “add track” then “group channel to selected tracks”

Ok, I’m not saying that isn’t broken, I totally believe you when you say it is and that it was a bug before. I meant showing that the procedure I described doesn’t work - i.e. Alt+Shift selecting the destination for multiple selected tracks.

Wow, I just uninstalled Cubase 11 and voila, everything is working as it should. Thanks again for helping.

Weird… Glad it works!

I actually have the same issues in Cubase Pro 13.0.20:

  1. Add group to selected channels does not actually route the selected channels to the new group.
  2. After multi-selecting channels and then assigning a new output in the routing panel of the inspector (while holding alt+shift), only the first selected channel gets its routing updated


yes, that is what was happening to me. I fixed it be uninstalling Cubase 11 which was the previous version I was working on and had the same issue. I upgraded to 13 and the issue carried over. If nothing else works I would try uninstall and reinstall.

Any more people with this issue? I also still had C11 installed but uninstalling that did not make a difference for me.

Ok I just found out that in my preferences, the setting for “Editing - Project & MixConsole - Sync Selection in Project Window and MixConsole” had somehow been disabled. Once I enabled this, everything was working again as expected. I don’t know if this is per specification but I’m glad it is at least working again.

This also solved my issue that I could not add a group channel to multiple tracks via the right click menu when multiple audio tracks are selected. I used to get a group channel but not all the selected tracks were assigned to that group channel.
Now that’s working again as well.

Just in case anybody is still having the same problem!


So interesting, as that was the interaction I noticed from the above video. Watch the mixconsole in the lower zone, an entirely different track is selected there from what is being selected in the Project window, and you know when the user has used the q-link command because that is the moment when the selected track picks up the pan settings of the track next to it. I do not believe this is intended behavior regardless of sync settings.

Ah yes you’re right, I had not even noticed that in the video.