Group editing not working due to tracks out of sync error

I’ve been researching this and cannot understand the reason or solution. I don’t remember ever having this issue. I track a lot of drums and have also overdubbed sections with multi passes before without issue. Recently I tracked 8 tracks of drums, cued up to the start ( snap to zero was off) played a take. Stopped and cued back to the start and recorded another take. I did this 6 times. The start points are the same but endings were stopped randomly when I was finished a take. I cannot group edit due to the out of sync error. So when I go to the lanes and try to audition different takes it does not work. How do I avoid this in the future and how do I fix so I can audition and edit my takes?

I viewed a Youtube video of a fix which called for editing audio - events to part, but this did not fix the issue.

Never mind fixed it

I recoreded 10 takes of drums today and my project is now in a state where drum-comping is NOT USABLE.
I can not really tell how I got there (mayby unintendently brought a track forward somehow?), but I have 10 takes on 16 tracks all with the same length and zero crossing off and am runnig version 9.5.30 that “fixed an issue” with group editing and zero crossing, so I would have expected that massive testing of this feature has been done recently at Steinberg.

Moving to foreground by comp tool or even selecting a lane (for example “use take 2”, I click on the snare track) now leads to selecting different lanes on some of the tracks (for example overhead left jumps to take 4 and low tom jumps to take 1).
I really consider this a bug.
I tried to get around this by disabling group editing and trying to align what is in the foreground manually by moving individual or all lanes to foreground, but as soon as I reenable group editing (without a warning) and try to comp or select, some different lanes are use.

If group editing is on, lanes should be connected by all means.
If there is any reason why take 1 and take 3 should be combined, disabling of group editing or a kind of “group override” (new “feature”) should be needed.

Lost hours today hunting for a solution and am very disappointed to find out the problem is around for so long.
Multi-Take-Drum-Comping was the only reason why I got the Pro license.

see and for others having this problem

Hi Guys,
lease support my two feature requests that will improve this drastically: