HALion 6.1.0: abnormally long GUI loading time

I am surprised this is not mentioned anywhere here in the forum.

HALion 6.1.0 interface takes nearly 20 seconds to display!
whereas HALion 6.0.1 takes less than 2 seconds.
I don’t even mention other VSTis such as Kontakt etc which load almost instantly (less than one second).

Maybe you’re already internally aware, but I’m wondering how is that HALion 6.1.0 have been released with such an obvious issue. I leave you to imagine switching in VEP between dozens of HALion instances!
Maybe something wrong in my setup. I’ve reinstalled HALion 6.1.0 at least 5 times with no difference.

see attached GIFs

Hi TheMaestro,
I have made several measurements (standalone, as plugin in Cubase with the default- and an extensive multi preset) but I can’t see any differences that would be worthy of mention. Can anyone else confirm the longer loading times since HALion 6.1.0 ?

best regards
Gerrit Junge

Just tried opening Cubase, creating empty project.

Inserting Halon 6.1.0

Took about 2 seconds for GUI to appear after I clicked.

Closed GUI, reopened it and while a slight delay, less than a second, as good as instant.

Completely closed Cubase. restarted Cubase and opened "Demo Project for Cubase Pro 9.5 (got a strange message about my Groove agent not having a license when it does, but will worry about that later)

Inserted Halion 6.1.0, took about 3 seconds for GUI to appear. Closed GUI, reopened it and it was as good as instant (didn’t get to 2 seconds on my stopwatch)

Thank you Gerrit for taking the time to test.

And thanks Ojustaboo for confirming.
So the problem would be on my side? But where?
This time I trashed the Preferences before re-installing HALion 6.1.0: no difference.

I did some tests again going back and forth from 6.1.0 to 6.0.1, opened HALion with default program Hexagon, and I always get the same constant results:

HALion 6.1.0 as VSTi in Cubase: 18s
HALion 6.0.1 as VSTi in Cubase: less than 2s
HALion 6.0.1 standalone: 13s
HALion 6.1.0 standalone: 38s
HALion 6.0.1 instance loaded into VEP6: 11s
HALion 6.1.0 instance loaded into VEP6: 36s

6.1.0 is 3 times longer to open in standalone or in VEP and 10 times longer opened in Cubase.

I also switched ASIO drivers and got no change.

Now the question is: where to investigate?
CPU, MediaBay … what could be the cause of this difference between 6.0.1 and 6.1.0?
I have no more idea at this stage.

It would be curious if I am an isolated case! as I have nothing “special” in my setup, excepted a rather old computer!

I just upgraded it and installed Iconica.
Now when i save s sesion template with 1 instance of 16 midi channels of iconica, it takes over 5 min to save !!! Then when i load a cubase template with one instance of 16 midi channels of Iconica in Halion it takes 7-10 min of rainbow pinwheel!!.
I then tried it in Motu DP 9, i created one instance of Halion with
One program of Iconica… it takes over. 6 min to save!!!
So then frustrated i tried logic and it crashed with Halion.
So then i reinstalled it, removed Prefs, tried cubase 9.5 Iconica DEMO sequence. It crased after 22 min pinwheel on loading channels. I tried it rebooted three times then it launched.
No sound then crash on thread 0 “Halion” sent to Apple in crash reporter. Called other film composers. EVERYONE has load hangs and errors. Main probkem in Cubase and MOTU is auto save locks machine for over 9 min to save Iconica program in HAlion.

The Emeperior has no clothes!!!

Major bug. Makes using Halion and sonic and Cubase unusable with Iconica!!!

A major problem.

I will save next crash fump and send it.

I had to create new orchestral templates without Halion because
It renderd Mac and composing impossible. Not to mention Hard crashing Cubase!!! Like all of a sudden nothing but desktop crash!! No crashreporter no nothing!!!

I got it to work in cubase and DP moti but turned off auto save and save takes over 6-12 min of rainbow pinwheel.

check your VSbasics, dot nets etc for tha latest versions if you use Windows 10, and sometimes your grapchis drivers suck, as on my system with an asus mainboard AND asus Radeon card. I use microsoft basic drivers there … AMD originals suck, also the newest … F