Halion 6 not loading some instruments but Halion 7 has taken over them

Since the introduction of Halion 7 some instruments have now not loaded into Halion 6.
Specifically Halion Symphonic Orchestra, Olympus Choir Elements, Colours Free and WAV CRE8 and the Poly.
They load and play fine in Halion Sonic 7 fine. I’m just trying Halion 7 and they work perfectly as well.
I haven’t had Halion 6 that long but just before the Free upgrade period for Halion 7.

Anybody else had this issue or got any work arounds?
Looks like they have bee programmed out of Halion6 permitted content. Dont really want to be forced to buy yet another upgrade.



Have you tried putting the dongle back your computer ?

Tried that no change.
Now checking to see if it works with all previous Halion versions deleted and just Halion 6.
Thanks for your help.

Due to the implementation of the new Steinberg licensing, instruments which are licensed via the Steinberg Activation Manager are not known by HALion 6. This is because HALion 6 is not compatible with the new license system due to technical reasons. So, only instruments licensed via the eLicenser Control Center can be used in HALion 6. But that shouldn’t be a problem, because you won’t have any advantages by opening these instruments in HALion 6. Since they are protected from deep editing, it wouldn’t make a difference if you open them in HALion 6 or HALion Sonic 7.



Hi Jan

The only issues with that is I would no longer have access to the features of halion 6 that I was using in projects. Flex phraser being one of them.

Do you have a solution for that ?



Ah, that’s an interesting issue. So you have Full H6 but only Sonic H7. And as the libraries are now on the new licensing, Full H6 can’t see them.

Damn, That’s a real muddle. Interested in what SB’s official stance is on this, as those libraries would’ve been updated without any kind of warning that you would lose them in H6 I presume?

Seems odd but Halion 6 will no longer support certain Instruments using the New Steinberg Licensing. Rather odd as somethings still work from the USB-Licenser and the Steinberg Licensing system in Halion 6. The instruments still load in Halion sonic SE 3 though.
What’s happened to Halion 6 ???

I would guess that the newly generated licence keys are not being accepted in Halion 6 due to the altered security keys or different algorithm used in Halion 7.

NON WORKING- Halion 6 -Amped Electra, Colours Fee, Halion Symphonic Orchestra, Iconica Ensembles, Olympus Ensembles, Poly & Wav CRE8

Everything based on Halion 7 will work fine as the license s are compatible.

Unless the licensing is looked into by SB then Halion 6 will soon be rendered useless for Instrument use.

A forced and costly upgrade to Halion 7 will be the only solution to regain full functionality.
Rather annoying as I’ve only had Halion 6 about 18 months now.

Will look at the problem again when I next get a free moment.

Good luck! If I find a solution will update.

There needs to be some sort of warning about this from Steinberg

1 Like

If you still have the “upgraded to Steinberg licensing” licenses available on your USB-eLicenser they should work with HALion 6. Make sure to have the latest version of the eLicenser Control Center installed, the latest version of HALion 6 and the Steinberg Activation Manager. The only issue here is, that you can’t use SAM based licenses in HALion 6. If there is a license available on the USB-eLicenser, and it is connected to your machine, it should work. That is why the “upgraded to Steinberg licensing” licenses remain on the USB-eLicenser.

1 Like

It was a clean install of everything downloaded through the Download manager and off the Steinberg download site so everything is the latest version.

It all went wrong when I purchased Iconica Ensembles and installed Halion Sonic 7 as recommended along with it.

I think Halion 6 is not reading the license references anymore as priority has be set to Halion 7.

Is there anyway to run Halion6 licenses manualy?


Does that work even if the content libraries have been updated then?
i.e. can the same updated library refer to either licensing system to validate.

There is no priority setting regarding HALion 7.

Neil, what about we first solve the problem via the ticket you raised and as soon as we have a result, you can go on posting? It doesn’t make sense to make any guessing here before we know what the problem is. I am in contact with the development and our license team to find out why you can’t use some of the instruments in HALion 6.

Best regards,


Hi Jan

Great idea. Let’s see if cause can be isolated.

Thanks again for your help.


Try this if Instrument Preview or Mediabay not working as expected after Halion 7/Sonic install.

The Mediabay program was running part corrupted with the instrument file call for the preview un resolved.

FIX - Uninstall Mediabay and reinstall. (Through windows App UNINSTALL) I used the Halion 7 single installation to re install and no issues so far.

Worked for me.

Now it also runs much faster for instrument selection.

This may fix other MediaBrowser issues as well.