Halion presets can not be loaded

I’m using Cubase 9.5 and Halion 5 + Halion Sonic 2. When I add an instrument track with Halion 5 og Halion Sonic 2 and try to select a preset I get an error message saying “The preset could not be loaded. This can happen when the preset was saved ny a newer version of the plugin or by an incompatible plugin.” The presets are working with the Halion Sonic SE.
I saw another forum post saying that an update of Halion is needed, but I have the lates version of Halion 5. If I want to update to Halion 6 I have to pay for it, shouldn’t I be able to use Halion 5 and the factory presets without purchasing Halion 6…?
Any help is appreciated! Thanks.

I’m having a similar issue. I recently installed Cubase Elements 9.5 and have tried to load presets within Halion Sonic SE 3. Whenever I select a preset, I receive the same error message. I just installed an update for Halion Sonic, as I had also read this might solve the issue, but I still get the same error. I don’t have this problem when loading any of the Prologue or Groove Agent presets.