Halion SE Soft elicenser installation failed

Hello everyone, sorry if this is the wrong forum to post this in but my issue pertains to my ability to use Halion SE on my current laptop/device.

When I open elicenser control center (Which has been uninstalled/installed numerous times in the last 24 hours and is fully up to date), it runs the standard maintenance check, but none of my soft licensers appear? I’ve checked my steinberg account information and I have the Halion SE software “activated” and was done so back in April 2020, but when I attempt to reactivate the elicenser it asks me for a new activation code which I am unable to provide as I can no longer see or find my current soft elicense under the elicenser control center.

I have follow all the steps in this particular thread (forums(dot)steinberg(dot)net/t/not-created-soft-elicenser-under-any-installation-options-w10-pro-1909-64bit/140308) and I mean all of them, including looking for any program data/system 32 files that may have been lingering in order to delete them, and I have attempted to run the “elc-installationhelper” only for it to say “Installation failed, soft elicenser installation failed” every time I try to run it (As administrator of course).

I’m wondering if anyone has any solutions to this at all? As I would absolutely prefer not to purchase a usb dongle in order to use an elicense, but with that being said I wanted to purchase a particular vst from steinberg and at this rate it’s redundant of me to do so as I can’t access the free player that could use that vst, unless I attempt to buy the full version of Halion 6 which I have no interest in, and at this rate it seems it wouldn’t work regardless as the soft elicense doesn’t appaer/won’t reinstall.

I would ask for help via support but all it does is redirect to distributors and there is no actual way to create a ticket.

Any help would be greatly appreciated.

Kind regards.


Look for reactivation in your Steinberg account

Thanks for the welcome, I have done that but it asks me for the reactivation license in order to do so, and because my soft elicenser isn’t showing up in my control center, I am unable to generate a reactivation license, I only have my previous currently “active” license, with that in mind “said” active license is not showing up nor able to be reinstalled in the elicenser control center.

No sure I follow- but it might not matter… Reactivation asks for the serial number of your soft elicenser, and then generates an activation code you can enter.

Is that what you are seeing/talking abut?

Not necessarily, so when I open the elicenser control centre, under my licenses nothing shows up, but on my steinberg account on the website it says that halion sonic SE was activated in april 2020, it has the serial number for the soft elicense, but the elicense itself is not on my computer, I have tried using the installation helper to reinstall my soft elicense on my computer, but it just says installation failed everytime. So in other words I have the sonic SE player on my desktop but am unable to use it because it cannot detect an active license on my computer, and when I open the elicense control centre there is no licenses there either.

so much info… there is no soft elicenser displayed in the elicenser control center is what I can make out.

See this: https://helpcenter.steinberg.de/hc/en-us/articles/206632670-Soft-eLicenser-virtual-license-container-is-missing

That is correct, and I have tried using that utility tool and when I get the following message at the end:

“Installation failed, elicenser installation failed”

That’s why I’m at the point where I am now, asking on the forums in the hopes that someone has a solution for this, thanks for trying with that anyway.

Have a look at this post: re eLicenser messsage - #9 by Dirk_Stegemann (Steinberg staff) says

I have tried both of those solutions and there was no success, I no longer have any elicenses on my computer, I’m hoping there is a solution where I won’t have to buy a dongle as I really don’t want to use one.

I’m not sure using a physical key would help this situation.

You mentioned that you modified system files, if that’s actually the case there’s no way to know what’s going on for a simple forum moderator such as myself.

I didn’t modify them, I deleted them as per the recommendations in another help thread, the thread above in my first post, just have to remove the (dot) parts of the link and add full stops in place and it will go to that link.

But yeah I get what you’re saying, it’s a super unfortunate issue as I wanted to buy a vst from steinberg to use in the halion SE player, but at this point it seems I have hit a wall in that regard, I appreciate all the help though.