Halion sonic 2 missing audio files

Hi there folks
I hope you are all creating hits out there,

I downloaded the upgrade from Halion Sonic 1 to Halion Sonic 2 from the online store.
I have successfully activated and registered the product.
I installed it as I normally would any other vst , all went smooth. It also opens just fine . I was scrolling through the sounds and still all seemed fine till I got to the brass . the first few patches loaded solidly and sound great. then as I loaded another patch I got an error message saying "some audio files are missing please check installation.

I have reinstalled it about for times but yet the problem persists.

The downloaded file was just over 800 mb which is what is stated on the site. What am I doing wrong? is there additional content which I am supposed to download?

please help if you can and thank you in advance.

have a fantastic day

I’ve got nearly the same problem only I can’t even select a single sound i’ve been trying to get an answer for about three weeks, though I’ll have to say that there was a problem with the email that steinberg explained. But after that I’ve sent another 2 questions. And Jan has answered on one of them the other day, but the following questions hasn’t been answered yet. I really hadn’t expected this from Steinberg.

Are you running Windows 8.1 Patsy ?

Hi KingRoy
i feel for you man.
i am am still running Windows 7 as i am not comfortable moving up to 8.

At least i got a chance to sample the sounds. They are great !!!

i hope i can sort this out.

i see in the read me files that you need 17Gigs free . the download is only just over 800mb so there must be more sounds to download.
i cannot recall Halion Sonic 1 being that big as to make up the 16gigs that i don’t seem to have installed.

good luck KingRoy

At first i ran it on windows vista and asked for support they told me eventually that it isnt Vista-proof. So basically decided to up the studio to windows 8 and I’ll have to say with succes. Had it completely runnin on win 8, but since I’ve installed cubase se 3 it gives me this bullsh*t … I cant seem to cope/deal with the fact that such a big company creates software wich can encounter these problems … And expected an solution of course …

Good luck with yours as well !!! :wink:

I’m having similar problems, some of the brass patches and acoustic guitar patches say they is audio content missing.Some of the guitar patches are fine, but all the 12 strings for instance have missing audio files.
So where are they?


You really inspired me for another attempt. After so many hours trying to get the install right.
Your thread made me try it again. And I finally got it back to work.

I’ll explain in order to help someone with the same problem.

OS : Windows 8
First I wanna add that I use the original Halion Sonic discs for this ( boxed ) ( I’ve purchased HS2 as an update )

First you de-install all the HS installations on the computer.
Than you install the original Halion sonic ( version 1.0.0 ).
Then you download the 1.5 content update from the downloads area on www.steinberg.net
Install this.

Then you download the HS2 update from HS1 from the downloads area.
Install this.

Make sure that when you install these you tick the box " all users " otherwise it’ll probally won’t work.

Roy. :sunglasses:

Thanks :smiley:
This worked for me too.

Thx a mill Roy.

that did the trick.

Youre a champ

OK, I’m having horrendous problems with hs2 not being able to find factory contetn samples. I purchased halion sonic 2 over the weekend (although I couldnt gt a demo license to work–I had another support request in for that). The program has installed, but about 1/3 of the Halion factory content can t be read. For some files, I get error measages saying the file cannot be found with an optin for me to locate it. I point right to the file, which is clearly installed at C:\Users\Owner\AppData\Roaming\Steinberg\Content\HALion\VST sound,

and the program still refuses to recognize it. For other sounds, I get a file not found error when trying to load them but no warning about missing files. For others, there is no warning or error message, just no sound when I load the patch. I’ve uninstalled and reinstalled more times than I could count today. I ve run repair options from both the HalionSonic2 64bit icon, the HALionSonic_2_Content and the HALionSonic_Content icons. The later two were in the download subfolder
HALion_Sonic_2_Trial_1\HALion Sonic 2 for Windows\Additional Content\VST Sound

Before this, I had needed to move the VSTsound files from part two of the download subfolder

HALion_Sonic_2_Trial_2\HALion Sonic 2 for Windows\Additional Content\VST Sound

to the corrspodning folder in the unzipped part 1 of the download. WIthout doing this the installation program simply told me that I was missing the contents from part two of the download and refused to continue installing. (There was no indication that these two downloads were supposed to unpack into the same overall folder and no automatic linking from one download to the other for installation.)

Earlier today, I just couldn’t get the cellos, acoustic basses, clavinets, flugelhors, french horns, dx, cp70 and cp80 pianos and chromatic percussion to load. Now, after uninstalling and reinstalling again I also cannot get the Rhodes and Wurlitzer pianos to work either. (THere are also a few others, but these are the broad classes that come to mind.) Other presets from the same library load and play properly.

Oh, after the first install, I also could not get most of the acoustic guitars to work. However, this problem mysteriously repaired itself during one of my reinstall or repair program procedures.

I’ve tried setting up the program during install to be available to all users or just to me. I’ve uninstalled and reinstalled both ways. At one point, a copy of the content was also deposited at C:\ProgramData\Steinberg\Content\Halion\VST Sound

I’ve tried having all of the content at one place or another or at both. I’ve tried pointing to the supposedly missing files at both loctions, with no success. I am really hoping someone can help with this. I’ve sent nearly this exact same message to steinberg tech support, but I’ve read disconcerting stories here on the forum of others having similar trupble in the past and not getting any help from them–so thought I’d try to cover my bases.

I wanted to give an update on the above. In contrast to lack of responsiveness from steinberg support that some others have compalined of, I have had very good prompt responses from support–which it turns out in the USA is handled by Yamaha. I’ve had most of the above problems fixed with reinsatallation from iso files provided to me by the support team. There are still some minor issues to work out with one set of missing content from the “pro” series, but I’m pleased with the cooperation I’ve received from steinburg.

Hello All:

I’m currently running Cubase 7.5 (Version on a MacPro (Mid 2010 model).
My machine has 8 Xeon Westmere Cores and 20GB DDR3 RAM.
My OSX is, Mountain Lion (10.8.5, Build 12F45 ).

I purchased and installed Halion Sonic 1.x a few years ago, and installed all subsequent updates. This version worked great.

Yesterday, I purchased and installed Halion Sonic 2.x upgrade.
I then successfully Authorized HalionSonic 2.x.

Today I created a Midi Instrument track in Cubase an selected HalionSonic 2. The Instrument appeared to load correctly. I then proceeded to load and tryout several of the sound-patches. Many worked well, though with some, I encountered many of the same issues discussed here, with regards to the error message, “missing audio files”, on several of the instrument patches.

I then proceeded and reinstalled HalionSonic 2.x. The issue was not resolved.

Next, I went to Steinberg’s Suppport Download section and acquired the HalionSonic2_update.dmg file, thinking that this might address this issue and resolve the matter. Upon attempting run the installer, I received the message, “file not recognized”. I’m rather perplexed by the matter; Why would Steinberg release a purported .dmg “installer file” that does not install itself as it’s design-tag would indicate?

I’m a bit frustrated, as I assume others before me have been too.

I would gratefully appreciate any assistance on these 2 matters. Thank You.

I have had exactly this problem. I upgraded to a new Apple Mac Mini and encountered exactly this problem. And the instructions given above to solve it also solved my problem. I think it is strange that there is no information given by Steinberg that this certain process is needed,


I’m having exactly the same issues after upgrading from Halion Sonic 1.5 to v2. Having the same configuration.
I’ll check if HalionSonic2_update.dmg file will help :imp:

Guys I have updated Halion Sonic 2 using the latest update but the problem remains.
I have logged an SR which includes the names of the sounds which generates the “Missing audio files” error and my complete list of .vstsounds files.
Hopefully I’ll get some useful feedback. I’ll keep you posted !!