HALION SONIC 3 - Audio files are missing

Reinstalled this plugin already 3 times. Getting the same message: “Some audio files are missing. Please check installation”.
The interments section shows a lot missing items. I believe it is not trial version and should work properly.
Please get back to me as soon as you can. I have a project to work on.



Image “Sounds2” shows how it suppose to look. I have almost a half of all instruments. :unamused:

Can somebody get back to me please?

Try uninstalling the libraries using the Halion Library Manager and Windows’ Programs and Features, then reinstall Halion Sonic 3 using the full installer.

I have the same with Halion 6 I installed) (today I installed) - lack of some libraries. At the installation, however, there was a message (black screen) that these were programming errors - incorrect parameters.

I reported this in the post entitled:
Halion 6 - errors in the installation of some libraries …”
I am waiting for an answer - but rather from Steinberg’s employees - because it is their problem - programming errors.

Eureka! I’ve fixed my problem! Today at night! Maybe it will be the solution for you.

As I wrote above and in the post: https://www.steinberg.net/forums/viewtopic.php?f=265&t=138661

  • during the installation there was a parameter error alert - then the Sounds of the Eagle and Skylab piano did not load. They were visible, but they did not load.

I did this:

  1. In Media Bay in “Select Content Set” - I chose “Eagle”.
    In the “Name” field, the names of the Sound were shown.
  2. I entered the name of one of the “Name” in the Search Engine.
    The search engine found it and loaded it.

From here it is OK. And the Eagle and Skylab piano normally work.

It seems that Halion (and Sonic 3) found the address of the appropriate libraries.

I do not know about programming, but I think there’s a mistake in addressing some libraries at the time of installation. That was a message like that. Bad Parameter.

One more note: You have to be careful what is highlighted in the Character field (in blue) - because sometimes this highlight eliminates everything from the “Name” field - there are no Names, as if there were no library.

And this should not be confused with Search Filters below - they fortunately have a star button at the beginning that makes everything available. But only for filters.

I do not know if there is a button to clean up the filtration and see all the sounds of the given Instrument - eg Skylab.

That’s what I managed to understand tonight. If I managed? :stuck_out_tongue:

Thank you for reply.
Where can I download the full version 3. I updated mine from version 2 and no link for full version.

Thanks

https://www.steinberg.net/en/support/content_and_accessories/steinberg_download_assistant.html

you need to use the Steinberg download assistant to download the full halion sonic 3 installer

Thank you, It looks like I fixed it.
Discovered something else. I saw on demo video the following:
Video – I have:
Organ
225 – 215
Guitar
238 – 202
Keyboard
151 – 134
Anima
251 – 201

As you can see, there is a difference in quantity. I wonder why,

https://www.steinberg.net/index.php?id=downloads_halion_sonic_3&L=1

maybe you need to install the latest software and content updates and it wil put the rest

Did install the latest version, now it shows that I’m missing a lot of sound librarys.
Guys, it’s not funny at all. I paid money to have this VST, not the problems.
Update.JPG

Please see attachments. What should I do now?

Install your VSTsound files in one folder, f.i in a VSTsound folder on anohter drive.
The installers usually put them here: C:\Users\Administrator\AppData\Roaming\Steinberg\Content
Do a search too, there might be other places …

Move them all from there to the new location …

Make shortcuts inside that new location after the move.

Move all the newlymade shortcuts back to C:\Users\Administrator\AppData\Roaming\Steinberg\Content.

Your errors should be gone … F

This worked for me:

https://www.steinberg.net/forums/viewtopic.php?f=265&t=143059