HALion Sonic 3 Fail message - Audio Files Missing (Solved!)

Recently upgraded from HALion Sonic 2 to HALion Sonic 3 and that has not gone smoothly. First a license issue occurred. Tried to get some help from the Steinberg Support but didn´t get any respond for month so i had to solve it otherwise. Several updates of the License Control Center and reinstallations of HS3 fixed that.

But after the reinstallation of HS3 another issue showed up. A fail message pops up at start saying “Some audio files are missing - please check installation”…

I have now reinstalled HS3 three times. Even uninstalled it and re-downloaded the files again. But the fail message still shows up at every start. Both in stand alone mode and when every time when starting a HS3 sound in Cubase.

The thing is I don´t know yet what audio files are missing. After clicking OK HS3 seams to work. At least with the sounds I´m using for the moment. But every time I load or prelisten to a HS3 sound the fail message shows up. Extremely annoying!

Anyone who knows what´s wrong?

(Running Cubase 8,5 on a Win10 system. Used HS2 without any problems before the upgrade)

Go to C:\Users{{USERNAME}}\AppData\Roaming\Steinberg\HALion Sonic_64 then rename mediabay3.db

Does that make any difference? Are you using the latest version of Halion Sonic 3?

Thanks, but I´m afraid that didn´t help.

But since this is out of my fields of expertise I just want to check if I got it right. Was I suppose to rename the Data Base File from mediabay3 to mediabay3.db?

And yes - it´s the latest version of HALion Sonic 3. I reinstalled the 3.1.0 update and content at every reinstallation of HS3.

Just want to add that I use Steinberg plugins only and that all of the other VST sounds work just fine, including HALion Sonic SE. This fail message only shows up for HALion Sonic 3.

EDIT: Can also add that I renamed the “mediabay3” file to “mediabay3.db”. When I open the folder now a new file named “mediabay3” has been created next to the renamed “mediabay3.db”.

I have investigated the HALion Sonic 3 content and discovered that the error is located to 4 of the HS3 instruments. Hot Brass, Skylab and Studio Strings do not work at all and the HS3 Combis only work partly. So there actually seems to be some audio files missing. As I mentioned I´ve reinstalled the full HS3 and content several times. And even redownloaded it more than once.

So why does this happens? Is it the installation that fails or are some files missing already in the download phase.

The only thing I know that is different this time compared to all other upgrades and downloads I´ve done in the past is that this is the first time I have used the Steinberg Download Assistant. But I can´t tell if that has anything to do with it.

Any more theories of what can cause this?

Again, thanks Romantique Tp for your first reply.

But since i didn´t fully understand I would really appreciate if you could explain again to what I should rename the Data Base File?

And after the other information I have noted above - do you still believe renaming the Data Base File will solve this problem?

Sorry, I was going to reply to this but I forgot.

The point of renaming the database file was to make Halion “forget” the files that it had already scanned. I was hoping that it would then be able to see the files in the correct folders. “mediabay3.db” is the original name, you’re supposed to rename it to something else so Halion is forced to build a new one.

It sounds like your Windows 10 isn’t setup to show file extensions. I would recommend you to enable that option.

Try running the Halion Library Manager application and use it to remove all libraries in the “Managed” tab. Run the Halion Sonic 3 installer again and make it reinstall everything, then apply the HALion Sonic 3.1.0 update. Does that change anything?

These missing content issues are kinda frustrating because nobody seems to have figured out what’s causing them. Sorry for any inconvenience this is causing.

Thanks again for your replies Romantique Tp. I have carried out all of your purposed actions but unfortunately the problem remains. But at least we´re getting closer to the core of this issue. It´s exactly those four sound libraries that´s in the “Managed” tab of the Library Manager that´s not working. All libraries under the “Installed” tab runs just fine.

Judging by your last sentence it seems like this is not the first Missing Content Issue. I hope Steinberg is working on a sollution.

I will try to make a call to the Steinberg support tomorrrow.

I had a telephone (and Teamviewer) support session with Steinberg today and - more or less by a coincidence - we discovered together what caused the problem. A human error. And that human is of course me… :unamused:

What I did at the start of the installation process was changing the destination folder. I´ve done that on several other installations before and that has not caused any problems - until now…

So when the installation was made to the default folder - Tada! Everything works as it should.

Learning things the hard way… :wink:

What do you mean by the “default folder”? You mean C:/ drive?

I have the same problem, but I can’t spare 27 GB on my primary disc for now.

Please let me know.

I´ve had this issue a number of times over the years and I can´t believe they never fixed this issue.
Today I re-installed my computer and of course the issue came back.

I installed everything to the default location, and then moved ALL libraries one by one using the new Steinberg Library Manager.
The path in the library manager points to the exact location the file is, and I have tried restoring the exact same file from one of my backups.
Halion Sonic still complains some files are missing.

Any thought?

This worked for me: