Halion Sonic 7 says no license after Dorico 5 install

I bought and installed Dorico 5 a few days ago, and whenever I create a project in the PLAY screen, the VST it gives me is labeled “!! Halion Sonic !!” - when I switch to HALion 7 - it says there is no license for the product. I downloaded everything through the Download Assistant and loaded everything in the Dorico 5 category. I’ve tried everything I can think of. I switched back to HALion SE from Dorico 4 and it will load, but I have to manually load all the patches.

I have reinstalled Dorico 5 and it’s the same.

Do I deactivate Dorico 5 and get a new reactivation code and try again?


Did you look in the Activation Manager for Halion 7? All you need is to open the Activation Manager, login using your mail id at Steinberg and then you should see all your licenses. Halion 7 might not be activated, so just click the button.

You don’t need any reactivation code anymore. Activating Dorico 5 is the same as Halion 7, it is a button in the Activation Manager. You can activate and deactivate it there as often as needed, without any code.

And no need to do deinstall and install the software over and over again, that doesn’t help.

When I go into the Activation manager all I see is Dorico 5. No HALion option. Even under “Not Activated” it is not there. Even though in the download assistant it says I have downloaded it from the Dorico 5 window, and I can find the folder.

I reinstalled HALion 7 and this is the window I get

Are you sure you have a license for Halion 7? This is a product that needs to be bought separately from Dorico 5.

Dorico 5 just contains Halion Sonic 7, which is the smaller version of Halion.


My apologies. Halion Sonic 7 is what I have been meaning. When I downloaded it from the download manager it was the Sonic version.

So when you go to Play mode, then setup the VST Instrument to Halion Sonic and then press the “E” button, does it open Halion Sonic?


Sorry for the german interface…

I torched everything and started over. And now I see the Sonic version in my VST.

My other question is, how do I make that the default when I load up a new project. Because right now it tries to load something different, and I have to go in manually and reset it, and then I have to go into the E button and reset every single instrument with the sounds that I want. They start out blank.

I mean, I only have to do it once, but still. I didn’t have to do that with Dorico 4.

Well I’m dumb. I figured that out. I think I’m good. Sorry for the bother.