Halion Sonic 7 Sounds Not Available

Hi @Dgrady04 , first I’d like to find out, if you have installed the sound files or not. Therefore, please run the attached batch file. First download it, then unzip and then do a double click on it and to let it run. After a few seconds on your Desktop the file VAEDiagnosticsReport.zip shall get created, please post that one here. Thanks
CreateVAEDiagnosticsReport.zip (817 Bytes)

Hey, thanks for responding. Here’s the file!
VAEDiagnosticsReport.zip (5.4 KB)

Thanks for the data. You have all the contents files installed but it looks like you have the file permissions not set properly and therefore HALion Sonic cannot see them.
It:s late here and I will check in the morning more deeply and come back asap.

Thanks so much! The sooner, the better. This is a time sensitive project that I have to turn in soon, but that doesn’t concern you much, so take your time! As long as I can get this resolved eventually.


Hey, I have changed some stuff since doing the diagnostic report, so here’s a new current one.
VAEDiagnosticsReport.zip (5.6 KB)

By the way, here’s a screenshot of Halion along with a pop-up that keeps appearing.

Right, you start getting there.

Have a look in the file SMTGContents.txt in your diagnostics report. In there are all relevant files listed. Some have “BUILTIN\Administrators” access rights, for some it just says “…”
In the end they all have to look same, namely with BUILTIN/Administrator.

How should I go about fixing that? Do I just physically type them in and save?

In the File Explorer, go to the respective files, right click and choose “Properties” and then go to the Security tab and there you can change the access rights.

Since you don’t want to do that on each single file, try to do the same on the surrounding folders and make sure that the setting gets forwarded to every file in the folder.

I think I almost got it, I just can’t quite figure out the next steps. This is where I’m at:

It’s getting late where I am, so I’m heading to bed, but I’ll check this out in the morning!

Simply click on Edit and then make the changes. You best compare the settings to the properties of another file where it is already set properly.
If you change the properties on a folder, click on the Advanced button then you see at the bottom an option about allowing child object permissions to be inherited.

Okay, I feel like the problem is so close to being solved. I’ve changed all of those permissions and can now see all the sounds in the media bay.

In Dorico, when I select the HSSE+HSO(PRO) playback template, all of the sounds are automatically imputed into their slots in Halion, except now, I’m still not getting any audio.

I was able to get sound once momentarily, but it wasn’t all of the instruments.
Also, the message: “HALion Sonic Some audio files are missing. Please check installation.” keeps popping up when I try to fix stuff.

Please do another run of my diagnostics script and post the result.

And furthermore, please create a new project from piano template, enter some arbitrary notes (does sound come out?) and then go to Dorico’s menu and choose Help > Create Diagnostics Report. That will also create a zip file on your Desktop, please also post that one . Thanks

Here’s the diagnostic:
VAEDiagnosticsReport.zip (6.2 KB)

And here’s the Dorico Diagnostic:
Dorico Diagnostics.zip (684.6 KB)

Also, when I typed in some piano notes, I could hear them on input and playback, however, when I went over to my main project, I still couldn’t hear anything

Okay, thanks. So the sound loading problem looks like it is solved.
But still you don’t get sound (most of the time). Looking at the diagnostics, I saw that you have HALion Sonic 7 installed. There is a known issue with that one and a workaround described in this thread. So please follow along that line and let me know how it then goes. Thanks

I’ll go ahead and try it, thanks! I’ll let you know how it went!

Okay, so I tried what the other thread said about using that file and running it in the background, and it almost worked. I have discoed that any instruments that have a full non-restricted range in Halion can and will make sounds. All the others won’t output anything.

Should I maybe just try switching to Halion 3.5? Would that work?

You could try, but I don’t think this will help in this instance.

Just for clarification, you do have the Dorico Pro license or some other derivate? Which playback template is set as default with you? What if you try the other playback templates?s

I do have a Dorico Pro license. I’ve been trying to use the HSSE+HSO (PRO) Playback Template, which is the one that hasn’t been working properly. However, when I use the HSSE (SE) Template, all the sounds do play, albeit at a lower quality. This should work as a temporary solution since I really just need to be able to hear the pitches right now, but not as a permanent solution.

I guess if it doesn’t resolve itself by the time I need the HSSE+HSO (PRO), I’ll just come back and we can see if anything else can fix it.

Thanks for all your help this far though!

I also had this issue, which I solved. I usually login on a user account with limited permissions, and have a separate admin account for installations and higher level access. I went into my \ProgramData\Steinberg\Content folder and updated all the child inheritances to read/write for admin and regular users. They all had wonky read/write privileges. Switched back to my user account, and everything works!