Halion Sonic SE ignores my set sounds, or program change entries

(Translated from German into English with Google translator)
Dear Cubase colleagues,
since a few days I have been looking for a simple and comprehensible solution to export midi tracks including preset sounds and import them in the same sound.
The problem is probably banal; the forum is full of similar or maybe identical requests - but unfortunately none of these solutions worked for me.
Therefore, I ask for kind support of any kind.

I load a Cubase 12 Pro project with 4 midi tracks, e.g.:
Gauge 01 Channel 01 - GM001 AcousticGrandPiano
Track 02 Channel 02 - GM034 ElectricBassFingered
Gauge 03 Channel 03 - GM016 Dulcimer
Track 04 Channel 10 - Drums

The tracks are connected to Cubase’s own HaLion Sonic SE on the corresponding 4 channels
Now I have tried several ways to make Program Change entries:
a) in the Inspector, b) in the List Editor, c) in the Key Editor

I already have all the variations known to me including Midi import and export in format 0 for Halion including the adoption of all program changes … etc… Settings.
And only about 3 - 5 times - with 40 - 50 attempts - the right sounds came out.
Mostly, however, only GM001 AcousticGrandPiano on tracks 1 - 3.
However, the drum track on channel 10 always works perfectly.

Somehow HaLion ignores my program settings (mostly).
I suspect some basic setting or an active filter is blocking my program changes.
If I load another VSTi, e.g. MIniGrand from the third-party manufacturer, I can perform any program changes. However, the plugin is also not multitimbral.

In the meantime, I have no further idea and hope for help thanks to your experience, also by phone call, chat or TeamViewer.
Kind regards - Tilley (Win10Pro64, Cubase Pro 12.0.40)


Switch HALion Sonic SE to the GM Mode, please.

Das Problem ist gelöst, vielen Dank an PAT und Martin Jirsak!

Allen Verzweifelten, die ihre HaLion-Einstellungen ebenfalls (selbst?) verstellt haben, soll diese kurze Zusammenfassung als Wegweiser für
“mehrkanaligen General Midi Sound und korrektes Reagieren auf Program Change Befehle” dienen:

Im Rack-Instrument HaLion auf “e” (Instrument bearbeiten).
Im Menü (GLOBAL / AUTOMATION) auf GLOBAL klicken.
Program Changes von “OFF” auf “GM Mode” umschalten.

Bei mir hat´s jedenfalls so funktioniert - nochmals Dank an alle, die sich hierzu ebenfalls Gedanken machen oder machten!

(Translated from German into English with Google translator)
The problem is solved, many thanks to PAT and Martin Jirsak!

For all the desperate people who have also (themselves?) adjusted their HaLion settings, this short summary is intended as a guide for
“Multi-channel General Midi sound and correct response to Program Change commands” serve:
In the rack instrument HaLion on “e” (edit instrument).
In the menu (GLOBAL / AUTOMATION) click on GLOBAL.
Switch program changes from “OFF” to “GM Mode”.

At most, it worked for me like this - thanks again to all those who are also thinking about it or made it!