HALION Sonic SE3 cpu usage too high

Cubase Elements 10.5 running on a high-end laptop i7 processor with 16GB RAM.

It’s impossible to use HALION Sonic SE3 with a sample rate of 96khz, as it’s causing too many CPU dropouts, even with a single program loaded. this happens when limiting the instrument’s cpu usage and using OSC ECO mode.

this is not a problem with lowering the project’s sample rate to 48khz, but I wish to keep it at 96khz. any suggestions or did Steinberg create an instrument that is just unusable at 96khz??

any advice would be appreciated.

You could try going into the options tab on the VST plugin halion se. You can up the RAM usage in to make sure it’s utilizing the RAM more than the disK or vice versa. You can read about it in the manual under the options page for the VSTs. It works for all of them.