HALion sounds not assigned to instrumental parts

I have just installed Dorico but every new notated project has the same string sounds, rather than the ones would expect to be assigned to each instrument stave. I have reinstalled the programme several times; also the VST plug ins, but to no avail. I was previously getting error message such as the one attached, but that appears to have resolved itself.


The computer used is a brand new iMac 27" with Sierra 10.12.6. Has anyone else experienced this issue but found a solution? Thanks.

Sorry to hear you’re having problems, John. Did you definitely run all three installers that were presented to you within the Steinberg Download Assistant? There is the Dorico 1.1.10 installer itself (you can ignore the 1.1.10 updater, if you see that), the HALion Sonic SE installer, and the HALion Symphonic Orchestra installer. All three of these have to be both downloaded and then installed for Dorico to play back sounds as expected.

If you are not sure if you ran the HALion Symphonic Orchestra installer, please check the following location on your hard drive:

/Library/Application Support/Steinberg/Content/HALion/VST Sound/VST Sound - HSO

If the installer ran properly you shall find in there the item FCP_SMT_001_HSO_Bass_Clarinet_Solo.vstsound, plus 25 similar items for other instruments.

Thank you both for your prompt replies. Yes, I have downloaded all three - and reinstalled them all several times. The Symphonic Sounds seem to work fine on the pre-installed demo. projects. I can also use some of Symphonic Sounds but not find the full range. (see screenshot). I assume in any case that they would automatically assign themselves to the various instrumental parts. I am also curious that the default playback template is always Sonic. Is that to be expected? My feeling, after gone through many of the fixes with technical support, but to no avail, that there is something fundamentally awry, though quite what and where is beyond me. I would also add that on several occasions since it was installed, Dorico has frozen and had to be removed by Forced Quit. Any further help is very welcome. Thanks.

Yes, it is expected that the default template uses HALion Sonic SE (or short HSSE).
HSSE can also play the Symphonic Orchestra sounds and it can do it more efficiently than the HSO player, because HSSE can produce 16 different instruments at the same time. This is better than loading 16 single instances of the HSO player. It saves memory and cpu. So you should actually never use the HSO player and always use HSSE.

Now back to the other problem with the string sound. Now that we clarified that you have the HSO sounds, I don’t quite understand where the problem is. Could you please elaborate again?

Ulf, thanks for that clarification. I have just set up two projects, one for single woodwind and one for concert orchestra. The only sound I am hearing on playback or when inserting the notes is a synthesised string sound, and only on the upper stave, in these cases, flute. If I play a demo score such as Hewitt Jones’s Dorico score, all the instrumental parts sound as expected.

What if you go to Play Mode and then choose from the menu Play > Apply Default Playback Template, does that change anything?

Also in Play Mode, on the right hand side is the “rack of VST instruments”. Left to where it says “HALion Sonic SE” are 3 buttons, the middle one depicting a strangely shaped ‘e’. Click on that and the HALion Sonic SE editor window will open. In there on the left are the names of the loaded sound patches listed. Could you either create a screenshot or write them down and post here?


Thanks . Applying Default Playback Template does not change anything. Attached is the screenshot requested. I have also clicked on ‘First Contact’ to show part of the menu.

Okay, so it looks like the HSO sound patches are not found.

Please try the following:
Stop Dorico and then delete the folder /Users//Library/Preferences/VSTAudioEngine.
That folder will get recreated and filled automatically during next start of Dorico.
Also, the next start will take a little longer than usual, because the audio engine will scan for available sound patches.

But how about after the restart, still the same problem? Even after doing the Play>Apply Default Template thing again?

I’ve had run-ins with “first contact” !

My problem was that I had a project created with Dorico with full library installed. The project was then opened on another machine where the library was not fully installed, resulting in the “first contact” patch being chosen instead of the correct instruments. When the student then closed Dorico down (and saved the project) and then re-opened on another machine, the original instruments were lost and “first contact” was still selected.

My work around was to export the project as an xml file and then import that into a blank session. Dorico then sorted out the correct instruments.

Tony, in your case the “Apply Default Playback Template” should do the trick.

John’s case is different, because that does not work for him.

I couldn’t find the VST Audio Engine through the sequence given, but did through a search. I deleted the VSTAudioEngine file, restarted the computer, and Dorico. The message came - ‘Audio Engine Process Died’ and the Dorico programme eventually exited itself.

I hope you still have it in the Trash and can recover it from there, because it seems to me that you deleted the wrong item, namely the audio engine executable itself. Then Dorico can’t find and start it and therefore reacts with that error message.

Please check following:
In Finder, go to the Dorico application, then right click it and select Show Package Content. Then navigate to Content/Applications. Is there an item VSTAudioEngine?
If not, try to recover from the Trash and if that doesn’t help, you need to reinstall Dorico.

For what I originally meant:
Change to Finder and from the menu select Go > Go To Folder. In the edit box then enter ‘~/Library/Preferences’ and hit return, Finder shall open a new window for you where you can browse that folder. Then delete the contained VSTAudioEngine item.

Thanks - sorry for that error. I found and deleted the VSTAudioEngine folder, opened Dorico which opened quickly s normal, the folder reappeared; I applied the Apply Default Template. Alas, still the same - synthetic string sound and just on the top stave of four woodwind instruments. The solution appears to be elusive, but your help is much appreciated. Any suggestions as to what to try next? Technical help just got back to me and have referred the issue to ‘the developers’. For what it is worth, attached is a screenshot of the preferences window.

John, if you open the HALion Sonic SE 2 window and then open the sound browser (as shown in your earlier screenshot in the thread), if you type e.g. “combi” into the search box in there, do you see any sounds listed?

Daniel, I’m running into a similar problem with HALion Sonic sounds not displaying in the sound browser window. I can’t change any of the sounds, although I used to be able to do so. Now there is nothing to select from. This is true for all scores I open, and new ones too. Scores in which I have changed the default sounds play as they should, but I am unable to change those sounds either. There are no sounds to select. How can I fix this? [Win7]

Sorry to jump onto an existing thread, but it seems to be a similar problem.


~Dennis

Hi Dennis,

Yours is quite a different issue, but easily resolved, see here: https://www.steinberg.net/forums/viewtopic.php?p=648462#p648462

I had this same issue. Patch window was completely empty although template patches played fine. Deleted the VSTAudioEngine folder and everything seems good now. Thanks.

Thanks, Paul! That solved it easily (but why does it happen? And will I have to do this again?)

Glad to hear that fixed it for you. This is just one of those occasions where the cache of the VST patch database needed to be reset. Hopefully it’s not something that would be needed regularly.