Hammerhead sync

Hi Hammerhead Users

I’ve just bought Hammerhead and have discovered a sync problem . Timing is out by a 64th.
I’ve contacted Bram about it and he quickly replied to say that he will look into the issue.
Any body discovered a work around, apart from making 64th note adjustments☺️



Have you tried changing Latency in Settings/Audio/Latency


Thanks for your reply. Yes, I’ve tried all the usual stuff.

To quote Bram, " I recently had a terrible time getting Hilda to sync and loop properly in C3, because it doesn’t always start from 0 when looping back (unlike all other hosts I know on iOS).
I’ll look into it. I had to complicate my timing code in Hilda specifically to make it work with Cubasis, but perhaps I can use the same workaround in HH."

I’ve been using Groove Rider recently and that’s fine. Perhaps Jim Audio complicated his timing code or was just fortunate it worked!

i have that too with pure acids midi output.
it’s clearly off, but when i record the midi output, its in time.
or maybe i got midi quantization on when recording?

Hi all,

Shared the topic with Bram…


Hi all

Bram has emailed me to say that he has looked at the issue but has not
found a sync problem. He asked for an example Cubasis file with the error. Unfortunately, however, I had to tell him that I’ve been refunded
for Hammerhead and have deleted it😔

If HammerHead works in all other hosts except Cubasis 3 it’s a Cubasis 3 issue not a plug-in issue.

I do hope the one-bar loop glitch which throws off timing will be fixed in the next Cubasis 3 update…

Yes, I think you’re right. I recall this sort of timing issue mentioned several times in the forum over the years.

Hi @dobidicus,

We’ve already exchanged with Bram regarding the topic.
To evaluate the issue we need a reliable repro unfortunately.


Hi Lars
As far as I remember, to replicate, simply do the following,

Write a pattern of any any length in Hammerhead and play it from Cubasis from the first beat at the start of a bar. I found that the first drum beat of the Hammerhead pattern was skipped. However, playing the pattern from a 64th note earlier in Cubasis would play that first drum beat.

Of course, I tried all sorts of things but sync was always a 64th out.

IOS 16.7.02

Hope that helps.

… using latest Cubasis version.

Hi @dobidicus,

Thanks for the additional info, which has been shared with our engineering.

Please check the topic again once we’ve released the next Cubasis update (which will take a moment still).