Hanging MIDI Notes

Hello. Hoping someone out here can lend some insight to an issue I’m having with MIDI note data getting hung during playback as well as when playing my keyboard. I have a new Akai MPK88 connected to a new iMac via USB. I also have a bunch of outboard sound modules connected to a MOTU MIDI Express XT (an old one with USB and RS422 for those old Power Mac computers). Both the MIDI interface and the MPK88 are connected to a powered USB 3 hub.

I connect the MPK88 to the MIDI interface via the MIDI OUT on the controller when I practice piano without running Cubase. This gets me direct access to my rack of sound modules.

When I start Cubase Pro 8, I disconnect the MIDI cable from the MPK88 and plug in the USB cable instead. From there, I select my devices from the Inspector.

When I use Cubase, I get hanging/stuck MIDI notes when playing and when playing back MIDI files. I tried this on two different sound modules chosen as destinations and got stuck notes when playing scales and running my fingers up and down the keyboard. (hello blisters!) Interestingly, when I use Halion Sonic SE, it works fine and no hanging MIDI notes!

When I close Cubase and do the same thing from the MIDI OUT on the MPK88 going to the MIDI interface , I can access all my sound modules and nothing sticks when I play! Only when running Cubase.

In summary:
Notes hang when using Cubase as I play my outboard gear - but not when playing Halion Sonic SE.
Notes hang when Cubase plays back sequences going to my outboard gear.
I typically only select my MPK88 as a source in the Inspector.
I only use the MIDI cable between the MPK88 and the interface when not running Cubase Pro 8 (for practice).

Any ideas? Please help!

Thanks in advance!

I just made a discovery that has only added to my confusion. I installed Logic X and tried it out and the problem isn’t limited to Cubase. I get stuck notes in Logic X as well. So I think either there is some issue with the way my iMac is handling MIDI data or the interface could be choking on the data being sent to it from the iMac. I’ll try different cables and see what happens.

No Luck. Changing the USB cable between the computer and the interface didn’t change anything. Still having hung MIDI notes. Any ideas out there?

Hi you,

to narrow down the Problems I would connect the midi out of your Computer to ist midi in and Monitor the midi data. This will allow you to see whether your Computer sends out complete Information (i.e. NoteOff whenever necessary).

All the best :slight_smile:

Elien, do you know of a MIDI Monitoring app for Mac that I can use to see the data as my DAW sends it? Cheers!

Hi you, I unfortunately do not know midi Monitors for mac . I use MidiOx under Windows and dont even know whether there is a mac Version for this as well.

But you could try the midi Monitor plugin in cubase. Simply Set up another midi track, assign the correct midi Input to it and insert the midi Monitor plugin. Thus you could Monitor the incoming (looped-back) midi.

Cheers, Ernst

Try to filter out aftertouch in Cubase, unless you really need it.

Thanks for the recommendation for Midi Monitor. Still new to Cubase Pro 8 and never saw that.

I inserted it into a MIDI track and played a C# minor chord and the monitor showed the Note On and Note Off messages, but I could hear the C# hang.
Screen Shot 2015-05-13 at 10.10.51 AM.png
Another thing I noticed as I played this chord a few times is that I could hear notes cancel themselves out. I think there may be some MIDI loop going on here and I can’t see how to stop it. Here’s a shot of my Preferences:
Screen Shot 2015-05-13 at 12.29.58 AM.png
After some research, I learned that MIDI is 8 bit and transmits 31,250 bits per second. My MOTU interface has USB 1.1 and is 412 megabits per second. The iMac is USB 3.0 and transmits 5000 megabits per second. Now, I don’t know if that means that USB 3.0 is sending data “faster” or that it is simply sending “more” data within each second. If 3.0 is in fact sending data faster, maybe the 1.1 can’t handle the data. However, I was only sending a 3 note chord, not a whole ensemble.

I’m stumped.

This maybe isn’t your issue, but might help if you’re using a cheap MIDI to USB link

I have had a problem with MIDI notes hanging recently. I blamed it on using an old Korg N5 keyboard as a temporary mother keyboard. Then today I switched to an audio interface (Behringer FCA610) which includes MIDI and all my problems disappeared.

My conclusion is that the cheap MIDI to USB link from Ebay that I was using is the problem. This one has a small plastic bubble with a couple of lights on it, two MIDIS in/out and a USB connection. The problem is that most of the time it works fine, then I get note off problems for a while seemingly at random. My message is, don’t be tempted by these cheap solutions. This one simply doesn’t work correctly all the time.


Hello Parrotspaain. I understand the risk of a cheaper MIDI device. Sometimes they can cause more problems than they solve. I opted to hedge my bets and get a midi express XT from MOTU. Certainly not cheap from my budget standpoint. There does appear to be a MIDI loop occurring somehow since I can hear notes cancelling each other out and I cant figure out how to stop it. Still searching for an answer. Been getting emails from Steinberg support as well, but no luck yet.

Have you tried filtering out aftertouch ? It can produce a massive amount of midi data that some instruments just can’t handle. Worked for me, when I had the same problem.

Hello peakae. I tried filtering all the different messages one by one and I still got hung notes. I had to leave notes unfiltered, otherwise I get no input or output at all. Still scratching my head here. I’ve engaged tech support too, but no solution so far. Once I get it, I’m popping the cork!

Hi you,

honestly speaking I do not think that the Problem is with cubase. Your “loop-back”-test Shows that all midi Information is transmitted correctly, but somehow your device does not react properly. So there seems to be something wrong with our external midi gear. Did you maybe connect a midi trough port back to the Computer/Interface? This might gernerate a midi Loop.

Cheers, ernst

Thanks, everyone for reading through this issue and for all your suggestions. PROBLEM SOLVED!!

Steinberg Support suggested using another MIDI instrument that has a USB port and connect it directly to the computer and test with that and bypass the MIDI interface altogether. Before I got to do that, I compared Logic X on my iMac with my Macbook Pro (since I had it installed on both computers). Logic X worked perfectly on the Macbook Pro. I contacted Apple Support. Did several tests over the phone. No Luck and it was presumed to be a hardware issue with the USB bus in the iMac.

Took a condensed version of my studio to the Apple Store and set up the iMac, interface, sound module, keyboard and reproduced the issue at the Genius Bar. Further testing there proved it to be software, not hardware. Made a painful decision to start over with a clean reinstall of the OS and manually install my programs again and see which one is causing the problem.

After reinstalling my OS, I installed Logic X, then the driver for the MIDI interface. Tested Logic - Problem gone.
Installed Cubase - Tested (with Logic X) problem still gone.
Installed USB MIDI Driver for Sternberg CMC controller. Tesed w/Logic X - PROBLEM REOCCURRED!
Contacted Apple for help removing the driver. They suggested another clean reinstall of the OS.
Reinstalled OS. Started over and installed everything so far without the driver for the CMC controller.
Discovered from MOTU website that there was also a newer driver for the MIDI interface. Installed newest driver.
Tested - Perfect!
Checked Steinberg website and found newer driver for CMC.
Installed Tools for CMC v1.1.3. Tested - Perfect!
Installed driver for Audio Interface. Tested - PROBLEM REOCCURRED!!
Contacted MOTU Tech support.
MOTU suggested reinstalling the MIDI driver again.
Reinstalled. Tested - PERFECT!!

The reason it initially worked on the Macbook but not the iMac was that the most current MIDI driver was installed on the Macbook Pro, but the older version was on the iMac. The version numbers were so similar (same digits, transposed) that I missed it (and the folks at Apple). Plus I didn’t have audio and CMC drivers installed on the Macbook.

Lesson Learned: Drivers are a pain!
Case Closed!

Interesting story. Pleased that it’s resolved, so that you can get back to the creative side of things!

Hello Vain Cookies thank you for your attention to this subject. I am having the same problem. if you please I have a question for you. what is your Audio interface?

Hello all Thanks to this post, which I read after I had posted my hanging MIDI notes issue (sorry); I want to thank all. the problem was simply gone when I plugged in a USB hub between the MOTU MIDI interface and my iMac. So it is an issue with USB 3 most probably sending too much data for USB 2 (on the MOTU) to handle.
I am now a very happy Cubase Artist user. Cheers.

I know this might be an old topic, but after my recent experience, I thought it might help.

I recently loaded the East/West Composer Cloud Collection, and overall, the samples sound great; however, while testing a few tracks, I couldn’t help but notice that certain notes would hang during very simple, slow, whole-note passages. Nothing that required a Panic Button reset; playing the hung note was enough to cancel it out. But this would be unacceptable under any circumstances, and so I set out to find the culprit.

I started by opening the East/West Play app to see if this was also happening here. Nope - all notes start and stop as they’re supposed to in all collections. That brought me back to Cubase (using C8 Pro here). I read the suggestions here, and about the only one that seemed to apply was unchecking Aftertouch. Still, that didn’t make any difference either.

Out of curiosity, I took a look at my MIDI Input setting - it was set to All MIDI Inputs. I then changed it to my main input (M-Audio Fast Track Ultra) - voila! :astonished: No more note hang. Anywhere!

This is one of those moments when it might seem easy to pounce on either East/West or Steinberg - but at the end of the day, the culprit was something small and stupid that we users could control. Hope this helps.

I’m having the same issue, and it’s incredibly frustrating. It happens like 1 out of every 5 times I record over a track. More often when I overlay a track, less often when it’s a new track, though it happens across the board at some point. Same issue, not reading note off messages, and the “note on” hangs usually to the end of the recording. Sometimes it randomly stops at an unpredictable interval, but not when I physically let go of the note.

Cubase Pro 8.5
MOTU Micro Express
Mac OSX 10.11.5

Any suggestions out there?

I went to MOTU and double checked that I had the latest driver, and re-downloaded just to be sure. Didn’t solve the issue.

I’m dragging this post out of the tar pits because this was exactly my problem and it wasn’t very obvious what the solution was. I added a ROLI Seaboard to my setup which worked perfectly. I hadn’t used my regular controller in a long time and today was using it for some piano stuff and the Kurzweil controller was having hanging notes on certain libraries, even if the ROLI wasn’t turned on. I had been using the “All MIDI Inputs” for years with my Kurzweil and never had a problem even when combined with a Korg nanoKontrol2 and a Breath Controller. It turned out that now I HAVE to select my controller specifically for my MIDI Input setting. So glad to have been able to solve this, it was driving me nuts. Hopefully this can help someone else in the same boat.