Hanging notes using breath controller

I’m getting hanging notes when using a breath controller.

I’ve tried two different breath controllers. One connected via USB and one via a USB midi interface. I’ve tried two different keyboard controllers. One connected via an RME PCIE interface and one connected directly via USB. (Class compliant)

I have done extensive testing and this issue does not happen within Reaper.

Here’s a screenshot of midi tools external midi analyser and midi monitor plugin within Cubase. They both show the activity that led to a hanging note. You can see that there are 3 note offs recorded in midi tools but only 2 in Midi monitor. I can reproduce this successfully many times.

https://image.ibb.co/dGRTWR/Hanging_note_Miditools_vs_midi_monitor.jpg


I’ve tried disabling everything in “all midi inputs” except those that were that were needed for this test.

I’m using windows midi not direct music.

I’ve contacted support as it seems to me, my screenshot shows there’s a problem within cubase here.

Anyone else have similar issues?

Have you tried Use System Timestamp ?
“I’m not using windows midi not direct music.”
So what are you using and have you tried both, with and without timestamp ?
If you have tried DirectMusic, did you remember to activate it in the Hammerfall DSP Settings/Global ?

Thanks for your reply.

Yep I’ve tried “Use system timestamp”

Typo in that bit I meant I am using windows midi and not direct music " :slight_smile:

I’ve tried both and yes I did activate the setting in the hammerfall dsp.

Bummer.
I have only had the problem in the past with a keyboard that when using aftertouch would have hanging notes.
I used the midi filter to exclude anything i didn’t want, and that solved the problem for me at the time.
In my case it was data congestion of a kind, never got around to pinpointing the problem as it somehow fixed itself.
Best of luck finding a solution.

Thanks. :slight_smile: I think you’re right with data congestion. I think there’s just too much midi going in for Cubase to handle :slight_smile:

In your pictures I see that the missing note off has the same exact timestamp as a controller message. I am sure that is causing this. Thing is it shouldn’t… I will try here too, I use breath too on occasion.

Maybe a thing to try. Use 2 midi tracks, one for the note and one for the BC. Make sure they are set to one midi in only not allmidi. Output both midi tracks to the desired eh synth/module/vst and record enable both. See if this cures it.

Thanks Vinark. Have tried mapping BC to QC which works well but is a bit cumbersome. Will try separate midi tracks. That sounds more manageable.

The interesting thing for me is that the hanging notes aren’t recorded in the midi part. They just exist while playing in…

Yes the timestamp thing points to Cubase having difficulty dealing with two lots of data at exactly the same time.

I use the BC extensively so would be great to get a fix. Not holding out much hope from Steinberg as the current support has been a bit…erm…flakey :wink:

I managed to get one hanging note on the first chord I played. But after that none. How far apart are your incidents?
Come to think of it I might have had the problem before but did not recognise it. I play a vl1m which is a virtual wind instrument by yamaha but it is monophonic and 100% breath controlled, so results with hanging notes are different. I did have some weird issues that would be explained by hanging notes.
Cheers
Vincent

Difficult to quantify. At least one a minute I’d say. I also get some notes that don’t sound when replayed…

I thought it was Kontakt but I have it also with swam instruments. I haven’t used VSL for a while - should test that…

When you got your hung note, was it recorded in the midi part?

I didn’t test that but I guess it was recorded ok cause I never had issues with recorded parts and I did in hindsight when playing live. Here the trick with 2 midi tracks helped. And after recording just drop the BC part in the main track. You can even leave the BC track for recording the next track.
I would report the issue and if you do, send me a PM, I will then contribute too!

Hi . The two tracks works perfectly. No more hung notes. I’m dealing with support about the issue at the moment so if you want to chip in as well please do. I’ll PM you anyway :slight_smile:

Ah great! At least it is 100% not a computer but Cubase issue then. Let me know what I can do.