Has anyone had this issue with VST Instruments?

I’ve had this issue a couple of times now and I’m trying to figure out 1) why and 2) how to prevent it from happening again.

On occasion when I have a VST Instrument like FM8, HALion, or others, and I’ve set the sound I want to achieve, record a track via midi, (not bouncing to audio), and then of course save it and move on to another track.

If I close the application for the day and reopen it, and play back the track it’s not the same instrument I’ve created. It’s the same plug-in, but what I get is a unprocessed sine, or default instrument. Then I can’t find the settings I’ve created and I have to start from scratch.

So what I’ve been doing as a work around is exporting the track to audio so as to save my recorded track. Not a good solution for me.

Has anyone had their VST instruments revert to default or have then change completely during a period of time when you close and reopen a project??

Very strange to me.

Thanks for any info.

This will sound silly but have you activated the VSTi’s? Because that sounds a lot like demo’s.
I am sure that is not the case.

It’s not silly. Yes, everything is activated and current.

It’s very strange. It doesn’t happen every time consistently. It’s very random.
I’ve had to get into the habit ( not really a bad one ) of having to save a new version before I close, just in case I reopen it and the instrument changes, that I have it saved on a previous version I can go back to.

This problem sounds weird to me , and after re-reading it, I can’t help but laugh a little at how odd it must appear.

Is it perhaps because you’re starting with a VSTi preset, altering it, but then not saving it as a new preset?

For example, if you start with a preset in the VSTi, then make your changes as per your taste, if you were then to unload that VSTi (e.g. via F11 or “Rack Instruments”), does it then warn you that you will lose your settings if you don’t save?

Is this problem manifested on any particular instruments? Conversely are there any that this does not happen with?
This could get tedious but it might be a good idea to explore this and keep notes as to what happens.
Have you set up a template that you use to initially set up Cubase for a new project? Try making a new one. Does it still happen.
Are you using an instrument track? I find that Kontakt sometimes drops out in this mode. (Makes no sound and has to be re-loaded.)
I would be interested to know the answer.

for some reason i guess your plugin info isn’t saved at all in the cpr.

If you put on autosave in cubase and it happens again, can you retrieve them with the bak files?
If so, the content in your cpr isn’t complete for some reason when creating it on your harddrive.

the fact that you get init or default sounds… i guess you start with these when creating your sounds ?

kind regards,
R.

Aloha m,

Here is an approach (nice avatar btw)

Try using the ‘List Editor’ to see if you somehow (accidentally) added
a ‘MIDI Program Change’ event to the track.

If it IS there, either remove it or change it to the sound (patch) that you want.

I doubt this is the prob because if there is a Program Change event, the sound would change
every time you restarted the track; (not just after saving the work)
but it is worth taking a look/check anyway.

Good Luck!
{’-’}

I have/had a similar problem, where some instruments in a HALion instrument rack switched to a GM version of that instrument -as in, a Drive pick bass turned into GM bass-, or seemigly random, like a strat turning into a GM kalimba. After seeing this post, I looked more closely, and found that the odd instruments matched what it said in the “programs” bar in their MIDI tracks. Don’t know why, because some of those who hadn’t changed said something completely different.

Anyway, those names are still messed up, but I tried turning off “Program changes”, under HALion’s Options->Global, and it seems to have worked. I tried it because the only option was “GM mode”, which didn’t seem like something you’d wanna use program changing for anyway. Might be specific to that VST, but maybe try something following that line of kinda-reasoning?