Has anyone successfully solved the riddle of getting a 7.1.4 group into the Atmos Renderer?

I have come upon the issue that it seems some others have with routing to the Atmos renderer. I too would like the sends for 3D reverbs to return with front and back height channels.

I’ve been trying to glue together a 7.1 (bottom layer) and a 4.0 (top layer) by making a 7.1.4 group that uses the sends to split to those busses, then route those into the renderer.

I am having 2 points of trouble here though:

  1. I do not see how to route the sends to the proper channels (how to take the top layer of the 7.1.4 by itself to the 4.0 for instance). The send panner does not let me specify which channels are going where. I find it really odd when digital routing is more convoluted and limited than actual patching in the physical world.

  2. The Atmos renderer doesn’t want to accept my 4.0 group as either an object or a bed.

Is there a solution for this?

Here’s what I wrote earlier:

There was an error which was fixed with the latest version of Nuendo. Is what I described not working for you?

Perhaps I should ask why you are splitting it into a top layer and a bottom one. Is it because you don’t have a 3D verb?

Anyway, I would think that if you create a quad group and you route it into a 7.1.4 group/bus you should be able to elevate it, no? And then front / rear should follow?

So, you are saying I should be able to simply add the 7.1.4 group track as an object in the Atmos renderer?
This doesn’t work over here. The 7.1.4 group does not appear as an input in the dropdown menu for objects, nor will it connect if I select “make objects from selected tracks”.

I am on the latest version:
11.0.20


If you do not have a 3D reverb, you can put a anymix upmix plug on a 7.1.2 group

I do have a 3D reverb, which is the primary reason I am trying to get a proper 7.1.4 group going to the Atmos renderer. The only reason for separating top and bottom layers is because the renderer has a limit for beds which goes to 7.1.2, so I tried splitting my group into two beds.

I used “make object from selected” if I remember correctly (I’m in front of PT right now and can’t check until later tonight).

Looking at your second image I see the 7.1.4 group as an object, and I see you don’t have a source track for it. But it wouldn’t be it’s own source, right? Above it the “Bed” is “7.1.2 music bed” and it has a separate source, “Atmos Bed”. I’m assuming you’ve routed the latter into the former.

So if you haven’t done any routing into the “7.1.4 group” then I wouldn’t expect to see an input. I also wouldn’t expect to see one if you’re sending to it from a bunch of different sources, since choosing one “source track” wouldn’t really be of value.

In other words: Did you try using it despite not seeing an input in the “source track” drop-down? Just try sending to the group, pan into it from the source, and see what happens. I think that’s what I did, but I’ll check later.

Just tried again and it works for me on 11.0.20. Make sure you have created the group as 7.1.4 and also selected an output with the same layout before you try to “make object from selected”.

Matthias,
I have read many other posts by you, and they seem very cogent, but I must say that your reply here is not coherent.

“Looking at your second image I see the 7.1.4 group as an object, and I see you don’t have a source track for it. But it wouldn’t be it’s own source, right?”

The group itself is the source. That is what needs to be routed into the Renderer.
It doesn’t matter what is routed into the group, the group is the “object” to connect.
I have a 7.1.4 group which, as I explained, I selected, then used “Create Object from Selected tracks” under “Functions”.

It (the 7.1.4 group) is not connected as an object here (in the photo); you are confusing the “Name” column with the “Source Track” column. The name is not a connection, it’s just a name, and I can write anything in there.

“Above it the “Bed” is “7.1.2 music bed” and it has a separate source, “Atmos Bed”.”

“7.1.2 music bed” is the just the name for the Atmos Bed group. The name is just a label, not another track, group, bed or object etc.

So, check this next photo and take a look at the “Object ID” column on the right:

There is no connected object for the slot named “7.1.4 Group”. It is an empty slot, and as you can see the “Source Track” dropdown menu does not show an option to connect my group track (named “7.1.4 group”).

So, testing even further I find that none of the following tracks will connect as an “Object”:
7.1.4 group
5.1 group
7.1.4 audio
7.1 audio
5.1 audio

We have to go all the way down to “Stereo” to create an accepted “Object” with a connected “Source Track”:

So this leads me back to my original question about splitting a group to get a proper 7.1.4 input into the renderer.

It looks like it would have to be done by splitting the output (of a 7.1.4 group) into at least three components:
A 7.1 group which feeds into the bottom channels of the 7.1.2 bed and,
Two stereo groups fed as objects and placed in the 3D panner to be the Ltf/Rtf and Ltr/Rtr pairs of the “.4”.

Yeah you’re right about that. Sometimes I don’t brain good.

But anyway, it works on my end. I set up the following:

A 714 Output set to ‘main output’ in connections window.
A 712 Group made into a bed in the renderer
A 714 Group to be made into an object - this has output set to the main output
An audio track with tone.

Check images.

I’m thinking the key step you may have missed was assigning the group an output of the required channel format before making it into an object in the… uh… AtmoswhateverthewindowiscalleditsaysADMauthoringforDolbyAtmosonitIguess…

Sorry, but I’ve already done that (set the outputs to the main 7.1.4 outs) with all of the above mentioned tracks (groups and audio) and it doesn’t work, nor would it even make sense logistically: none of the tracks going into the render even need an output selected (on the VST console) simply because they act as send outs going into the renderer and this makes the console outputs mute, so if it were a requirement inside Nuendo as such it would be nonsensical from an engineering perspective and is probably only extant as some vestigial design for the routing.

Anyway, to be sure I tried it all again from scratch:
a brand new file in Nuendo 11.0.2, creating all the proper outputs and tracks for monitoring etc. and still the authoring for Dolby Atmos will not accept my 7.1.4 (routed to my 7.1.4 output) as an Object source.
Doesn’t work here.

:frowning:

I’m aware that this doesn’t appear to make sense. I think it’s just that the sends follow outputs as far as available channel configurations go, which is normal I think. Vestigial design… one way of looking at it. Seem ‘clunky’ and I know some have had opinions about the lack of metering when it’s done this way.

As for your actual problem and it working for me: I don’t know what to say then. It just works for me I guess. What’s your system? I’m on Win 10 Pro.

Do you want me to send you just a small .npr to see if my project opens fine on your system? Not sure why it would, but you never know…

Sure! Do you want me to PM you an email address?

That’ll work.

So I opened your file and indeed, the 7.1.4 group you have is routed as an Object in the renderer! I noticed that you had the renderer on the output bus instead of a group, so I changed that on my version to test it and it still does not work there.
I ended up gutting your file (you have so many outputs!) and keeping just your 7.1.4 object bus. I took the renderer off of the 7.1.4 output and put it on a group and put it on a group and it retained the previous 7.1.4 group as an object! Weird.

I will do some testing on it tomorrow and see what I can do with it- if other tracks can be properly routed as objects.

I did get a bad sign on exit though as the program hung. I had to “end task” to shut down properly.