Have echo on audio


Using Cubase 7 AI and I hear an echo on the audio output although latency is about 3 ms (difference between input and output latency) so in theory I should not be able to notice an echo! Any suggestions on how to remedy this?

My application is a sort of a “live” one where I am feeding audio into line 1 from a microphone (mono audio) using balanced XLR cable and then taking audio from 1/L (mono) into the input of a shortwave transmitter putting DAW processed audio on the air.

I have some difficulty configuring the output to be MONO…Input is configured as MONO.

Please, advise what I may be doing wrong?



I have a good output on the Steinberg UR22 but I still have an echo on it although latency is 3 ms!?? I am attaching a few images here to show the hardware I/O and audio I/O are set up.

How do I remove an insert? I’ve tried right-clicking etc. ? I assume that when an inserts changes from the gray color to say blue it is not bypassed but active (of course, I should be able to tell based on the sound!).

Would appreciate guidance on why I am still hearing an echo on the output!



Hi JJ2013,

on your UR22 there is a knob called “Mix”. What is its current possition? If you have it somewhere in the middle, then that is the problem. You should have it all the way to the left (Input) to monitor your input signal or all the way to the right (DAW) to monitor the output of Cubase.

Hope this helps

Hi ! I have the same problem here.

I’ve tried the “Mix” knob. On the left (Input), I hear echo and on the way to the right (DAW) there is absolutely no sound, as if the volume was OFF.

This is not a problem from CUBASE because when I’m doing record tests, audio is clean at the end, but always feel echo in my headphones, even not using CUBASE.

I need help.

Because you probably have plugins in your signal path with a high plugin delay. These do of course add up to the latency caused by the soundcard bufferrs.

I was almost going crazy about the echo on my audio interface. Since I could also hear it clearly without the computer it must have been somewhere IN the UR22C and not in the Cubase software or somewhere else. And finally I found this little app “dspMixFx UR-C” which was installed along initial installation of the interface box. (Just use the Windows Start menue and type “UR…”) There I could adjust the “hall” effect and the unwanted echo as gone! Try it out.