Having trouble with tablature when the same pitch is sounded on multiple strings (Dorico Pro 4)

I’m having some difficulty getting Dorico to show both tablature and and notation correctly on mountain dulcimer. It’s common when playing in DAA tuning to have the same pitch sounding on both A strings, but I’m having trouble getting both the notation and the tablature to look right – so far it’s just one or the other.

For reference, this is what I used to do in Sibelius by creating a voice for each string.

Screenshot 2023-06-17 020537

In Dorico, the notation looks correct if I use a single up-stem voice, but then the fret is only indicated on one A string.

Screenshot 2023-06-17 020156

If I try to fix this by creating a voice for each string, the tab is correct but the notation looks unpleasant.

Screenshot 2023-06-17 020230

Is it possible to get the 2 up-stem voices to stem together, the same way they would for a chord in one voice? I tried all of the voice options in Notation Options, but it didn’t seem to make a difference.

I think probably the best way to achieve this would be to add a unison notehead to the up-stem voice, then hide it via the Hide notehead property.

One can also edit the TAB notation directly to add or change fingering or strings.

If I edit the tab directly, Dorico adds it to the existing down-stem voice.

Screenshot 2023-06-17 120329

This is actually what I pursued at first, thinking I could fix it in engrave mode, but I couldn’t hide the extra portion of the down stem linking the two notes – I could only hide the entire stem.

Now that I think about it though, I probably could fix it by linking the lower D & A string together in one down-stem voice (since they are rarely in unison), and letting the melody have the up-stem voice by itself.

I did finally get this solution to work. I’m not sure what I did to finally get Dorico to put the notehead where it did (it’s been putting it off to the side, like the third screenshot in my first post, or putting it in a chord with the downstem voice like the second post). Is there a consistent way to get Dorico to put the notehead where it did this time, so I can easily hide it?

Screenshot 2023-06-17 194313

To input a unison, it’s as easy as selecting the note, shift-I, 1, enter. Why don’t you want to keep it visible is what baffles me in this whole thread. Since that note is played twice (on different strings) I would definitely recommend it to be visible. My 2c.