Hearing my voice without delay

I have the Steinberg UR12. I’d like to her my voice through my ears as I talk, but there’s a delay. Any idea how to eliminate the delay? I clicked the listen back box in the recording tab of my sound settings and here we are. Any help would be appreciated.

As you described it, you were monitoring through Cubase which always introduces some delay (latency). This delay can be mitigated by reducing the buffer size in your audio driver settings. Another, and a preferable way, is to utilize hardware (direct) monitoring. Instead of passing your microphone signal to the computer and back, you can listen to it directly via your audio interface. Steinberg UR12 has a dedicated button for this function: Direct Monitor.

1 Like

And welcome to Steinberg forum, @Sogiki :slightly_smiling_face: