HEJI accidentals playback with Kontakt

I am currently on Dorico and Kontakt 6.7.1. I understand that Dorico sends VST2 detune parameters to sampler instruments for microtonal accidentals such as HEJI. The Halion instruments tune perfectly. Kontakt instruments haven’t responded thus far and are fixed in equal temperament no matter what accidental is applied. I would like to use Cinematic : Cremona Quartet instruments. Is there any way to be able to work with these instruments using the HEJI accidentals? Different software or updates that will make it work? Suggestions? Thank you!

If you update to Dorico 5, you will gain the ability to use MIDI pitch bend for microtonal playback with plug-ins like Kontakt that don’t support either VST3 note expression or VST2 detune.

Thank you for the tip, Daniel. I upgraded to 5, my file is still playing in ET. How do I tell Dorico to use MIDI pitch bend with Kontakt?

The missing step is that you need to go to Library > Expression Maps, find the expression maps you’re using for the instruments that are playing back in Kontakt, and for each one, expand the top Expression Map Data section in the dialog, then set Microtonality playback to Pitch Bend.

Hi Daniel
I did this and the Kontakt instrument still plays out in ET. I have rebooted after making changes. I have been changing mod settings in the Kontakt instrument to automate from external source and still no success. Researching videos and manuals in both Kontakt and Dorico. Any help would be appreciated.

If you apply the HSSE+HSO (Pro) playback template to your project and play it back, do you hear the expected microtonal pitches (even though it’s not the sounds you want to use)? If so, that should at least rule out any problems with the setup of your tonality system.

Yes this works! But how do I make it work with my custom Expression Maps? I will now build new Expression Maps in Dorico 5 and see if it works. Thanks!

Building new expression maps in Dorico 5 for Kontakt Cremona Quartet for the HEJI accidentals using Microtonality Playback set to Pitch Bend is producing nearly expected tunings most of the time but the VST HALion instrument played exact target frequencies. Is using midi for pitch bend less accurate that VST?
I have one more question. Some of the key switches don’t turn off and go back to Natural. How do you tell the key switch to stop if the next note has no expression specified? Pizz and Harmonic turn off but other expressions don’t. One of the expressions will not play even though I have specified the correct key switch. How do you trouble shoot this?

You probably need to check whether you have set playing techniques as attributes or directions and make sure you have mutual exclusion groups properly set in your expression map (for instance spiccato and legato together, pizz and nat. together etc)

Regarding the accuracy of pitch bend vs. VST3 note expression, the resolution of MIDI pitch bend is indeed pretty limited compared to what can be achieved via VST3 note expression, because of the limitations of MIDI (you only have 8 bits to work with for any MIDI message). There’s also the vagaries of how a specific plug-in interprets MIDI pitch bend, in particular what its pitch bend range is (which unfortunately Dorico can’t detect – you have to work it out, and then specify it in the expression map).

I am finding that even with the HALion violin instrument, and the HSSE+HSO Pro playback template the microtonal tunings can unexpectedly play out in Equal Temperament. Please advise. Thanks–

Can you provide a minimal example that reproduces the problem? Cut the project (or, rather, a copy of it!) down to the smallest number of bars and instruments that still goes wrong, and upload it here.

Thank you Daniel, here is the file. This morning it is working correctly but sometimes multiple accidentals play out in the same half step.

HEJI accidentals at 440 test.dorico (1.18 MB)

I can’t see any obvious configuration error in this project, and indeed it seems to play back with the appropriate microtonal pitches (though my ear is far from well-attuned to the specifics of just intonation). If you can divine any pattern to when the playback is incorrect, please let me know.

But Pitch Bend messages are 14 bits, so it should be as accurate as the VST parameter (more, in fact, but this depends on the receiving instruments). If Dorico uses only values 0-127, that’s rather coarse. Then, I’m not sure if any VST instrument, Steinberg’s own included, can produce the 0.1 cent interval commonly used as the smallest step in Just Intonation Tonality Systems in Dorico (12000EDO). The VST parameter is editable in Cubase but only at 1 cent accuracy.

Did you check if the MIDI notes, rather than the microtuning / pitch bend values, are correct? There’s a known bug in the pitch bend microtuning export: for some microtuned notes, Dorico uses a wrong MIDI note (one semitone off), but the pitch bend value is correct (for the right note).

Hi Daniel
I have attached a file demo of a scale tuning that documents inaccuracy of microtonality tuning using midi pitch bend in the expression map for a Kontakt instrument. The Steinberg HALion sonic VST violin plays in tune but has heavy vibrato which is not workable musically to represent these precise tunings. I look forward to future developments, until then I join many of my colleagues in resorting to course alternatives such as sinetones in a DAW to represent compositions for the musicians that will perform our works.

HEJI accidentals at 440 test.dorico (1.42 MB)

1 Like

If it would be desirable to use pure tones in Dorico to represent the precise tunings as clearly as possible, whatever plug-ins you’re using in your DAW to produce those pure tones should work equally well in Dorico, for what it’s worth.

Hi Ellen,

I noticed that in your expression map for Cremona Violin 1, the pitch bend range was set to 13. From what I can tell, Kontakt 7 has a maximum pitch bend range of 12, but defaults to 1. If I set the pitch bend range in the expression map to 1, and leave Kontakt at 1, the Cremona violin seems to be playing the notes on the upper line.

Thanks Chester!!! I am thrilled – that works – setting the expression map data / pitch bend range to “1” plays the instrument in tune!!! I have no idea why…

1 Like