Helix Native not working

I am using Cubase Elements and trying to use Helix Native. HN is getting the signal from CE, but I do not hear the effect, nor do I see the output meter going up on the HN interface. I am using a PreSonus AudioBox iTwo interface, and so far, this has been a nightmare of a time vampire just trying to get this to work. I have tried other DAWs, but nothing seems to work. CE and HN came as a bundle with my Helix Floor, so I assume that these are compatible with each other. What I don’t understand is why I’m not getting the effects from HN even though I can see it’s getting a signal.

Perhaps you could post some screenshots showing how this is setup. Especially the routing to and from Helix Native.

While the two Helixs (Helixi?) are compatible, meaning you can load presets between them, they operate independently. Just like 2 floor units would.

Thank you for your reply. I have figured out the issue as far as getting the output to work. It’s been trial and error, but I got. However, I have the same problem in Cubase as every other DAW I have used with Helix Native. The clean is coming through as well as the effects. I know this because when I turn the level down on the distortion block in Native, I can hear the clean guitar, which means I must either be getting two signals (I don’t think), or there is some way of turning off the dry signal to Helix. Thanks again for input, and any other input you may have for this new problem. I am using the PreSonus iTwo interface, and I am aware of the insert vs playback knob, and it is turned to playback.

Using the Helix as a Send rather than an Insert could cause this to occur. But your pic shows you are using it as an Insert, which means that it has to be the result of the internal patch routing in Helix. Can you post a screenshot of the Helix Preset. Also indicate which control you are adjusting to change the distortion level.

Can you elaborate on what you mean by “clean guitar” - is that like 1) an undistorted but amped sound like a jazz player might use, or 2) a DI signal straight from the pickups?

Thank you for the reply again. My guess is that it’s something with the interface, which is the PreSonus AudioBox iTwo. I’ve given up trying to get it to work and am returning it to Amazon. I will find something else. I was using one of the distortion pedals on offer with the Helix. When I turned the level down to zero, I could still hear the clean coming through. The knob on the interface was in the correct position at “playback”. I agree with you that it’s some issue in the routing, but this occurred with ever single DAW I tried, including Abelton Lite, Studio One, Cakewalk, Waveform and of course Cubase. It’s as though there were two signals going through the chain, one wet and one dry. If the problem could be solved, nothing in three days and many hours of searching on the internet, troubleshooting and trial and error, nothing solved the problem. My money is on the interface. Thank you for your help and feedback. I’ll try with something a little higher end and run it through Cabase using the Helix Native plugin and see if I get the same result.

That sounds like you have Direct Monitoring enabled on your interface. You should be able to turn it off.

Yes, it was turned off. The knob is either set to inputs or playback, and it was on playback. I agree that there is some direct monitoring going on, and there is no way to adjust that on Helix Native. I even tried inserting Helix Native on the output channel, and that didn’t work either.

Well if it is Direct Monitoring that occurs before the Audio even gets to Cubase. You can test to see by Muting the Audio Track and the Stereo Out Channel in Cubase. If you still hear the signal then that’s occurring at the Audio Interface.

Can you edit the Title of this thread to include your Interface’s name, which will hopefully attract the attention of someone who knows it.

Happy to edit the title of the thread, but I do not see the option to do so. I ended up ordering an Motu M2. Hopefully that will give me the desired result. Thanks for all your input. Much appreciated.

Thank you for the reply. I don’t have the ‘pencil’ button to edit the title. I did figure out what my problem was with hearing clear channel. The problem was I imported my entire setlist from my Helix Floor. I had one signal path saved for vocals and one signal path for guitar, since I do both live. While in Native, it only recognized a ‘host’, so my guitar was going through what was supposed to be the vocal signal change. Helix Native has to be the most un-user friendly app I have ever experienced. I understand the scope and depth, but man I have wasted countless hours trying to just make this awful program work for me so I don’t have to keep swapping out my floor every time I want to practice. So now I have discovered a new problem, that which the title is applicable. I cannot save any presets. Every time I change the parameters on a block, as soon as I go back, the settings go back to the original. There is no place to save the preset in HN, but there is Cubase Elements 13, but when I go to reload the project, my settings are not saved. You’ve been very generous with time and helpful. Perhaps you can point me in the right direction on this separate issue as well. And not to continue whining, but I had I know what a time vampire a simple interface, DAW and plug-in with Helix Native, I would have never even started down this nightmare of a road. Thank you again for your time and input.


Not at DAW so some lingo may be off. For me the Native version works pretty much the same as the program (blanking on the name) that you use to edit the floor unit and presets are saved in banks & slots just like with the floor unit.

I figured out how to save changes. You have to save it to your library every time you make a change, much the same as when you make a change on the Helix Floor. The big difference is that there isn’t a nice big SAVE button anywhere to be found on Helix Native like there is on the Floor unit.

I want to thank you again for your time, help, input and most of all your patience. Best of luck, my friend.