Help: add key signature doesn't change my alterations?

I wrote some notes without key signature:
written with no key signature.png
and after i put or change the key signature:
key signature added.png
where is the option that will adapt the accidental?
Thanks best regards

no B E A to correct !!
change G# to Ab and D# to EB and they will adapt

Thanks for the answer, but don’t see where to write this or do you mean to change each note one after the other?
the music written in the example is only a small passage as test
Best regards

I suppose this is a midi import? try Music xml ?
As midi doesnt make a difference between C# and Db You will have to check this manually and do enharmonic shift
In Dorico/preferences/Key commands search “Respell” for your key command. Eventually change the not so practical default for our “French-Swiss” keyboard.
BTW I wouldnt like that Dorico respells automatically my “chromatics” !!

It will be easier when we have a complete search, filter, select, as in “S…s”

And If I really dont understand what you search for call me :=)

No, Dup obviously just entered some notes in C minor but with no key signature. This is where some sort of “retranscribe” feature would be helpful. Add the proper key sig and then ask Dorico to rewrite a passage accordingly. Or maybe it could be an option with adding a key sig, similar to rebarring with a new time sig. I’d expect this would be easier to do in the Dorico environment than in e.g. Sibelius. Is this sort of thing on the list, Daniel?

We will indeed have a feature to perform contextual enharmonic respelling over a passage of music in due course.

I suppose this could be corrected with the “modal zone” I requested last week.
Dorico won’t change pitches when you change a key signature, it respells the recorded pitches accordingly (which makes totally sense, of course).

thanks for your help.

For example I record a piece, which modulates between different keys. I use the recording function in Dorico. Afterwards I want to change the key signature so it is easier to read (I don’t want to change the pitches). Sometimes Dorico changes the accidentals, so it is in the correct key, but if sometimes it only changes the key signature without changing the accidentals. Do you have an idea, what the problem could be? I use Dorico

Best regards

Having changed the key signature, try selecting that whole passage, including the key signature, and then transpose it (say) up by a half-step, and then back down to the original key. That will cause the accidentals to be recalculated.

1 Like


unfortunatelly this still doesn’t work.

For that particular passage, try selecting the notes and using Write > Respell > Respell Using Note Name Below.

That worked fine. Thanks for this fast and great support!

Best regards