HELP - Basic Copy/Paste problem!!!

Wow, this one’s crazy.

I discovered that Explode wasn’t working, and in the process of trying to figure out why,I found that Copy wasn’t resulting in activating Paste or Paste Special/Explode.

I restarted Dorico, and the first problem was solved. However, items copied to the clipboard (Cmd-C on Mac) weren’t replacing the items previously copied to the clipboard; if I copied something it pasted fine, but if I copied something new and tried to paste it, it pasted the first copied item, not the new one.

I checked to be sure it wasn’t happening in other applications, I rebooted Dorico, and I rebooted my computer, but the problem continued.

But scariest of all, I closed the project I was working on and opened an older project. I copied a measure in the bassoon 1 part and tried to paste it into Bassoon 2, and what pasted was the last bar I had copied in the previous project.

Anyone else experiencing this? Any suggestions/ideas?


I can’t offer a solution, but this did happen to me, as well. I copied a passage, pasted it, only to find it was a passage I had previously copied - not the most recent one. The only thing I could think was that I somehow had not a.) fully hit the command-c buttons, or b.) I had some popover open that was out of sight, so while I thought I was copying a passage, I was really doing something that Dorico couldn’t understand, exited the popover. When I went to paste, it gave me the one passage I had actually copied. That’s the only thing I can/could think of; don’t think it’s happened again.

But it did happen.

I’ve never heard of any problem like this before, Lew.

Just to point out one thing: it doesn’t indicate any kind of problem that after closing one project and opening another, when you paste into that project, you would get material from another project pasted. That’s sort of the point of the clipboard, of course, so that you can copy and paste between different projects. Dorico’s clipboard is not project-specific, i.e. there’s a single clipboard and you can copy material from any project and paste it into any other.

It sounds to me as if for whatever reason Command-C is only intermittently working. Perhaps the issue is that your project is sufficiently large that copying to the clipboard is very slow (though I don’t think that’s in general something where we have had bad performance). If the problem persists, please try restarting Dorico, then start a new trivial project, write a couple of bars of music, and then try to copy and paste it. Do Help > Create Diagnostic Report and attach the resulting zip file here.

Here’s the file, Daniel. I am at a total loss — the Cmd-C keystroke does nothing at all now. The only way I can copy anything to the clipboard is to physically choose the Copy menu item. I don’t know if it’s relevant or not, but if I use Keyboard Maestro to make the Cmd-C keystroke trigger the Edit:Copy menu item, that works fine. So for now it’s working, it just isn’t working the way it’s supposed to.

Thanks, as always.

Dorico (432 KB)

Lew, can you try backing up the keycommands_en.json file in /Users/your-username/Library/Application Support/Steinberg/Dorico 2, and then restart Dorico and click ‘Reset Key Commands’ in the Key Commands page of Preferences. Does that get Command-C working again?

Yes, that worked. And when I put the key commands_en,json file back into the Application Support/Steinberg/Dorico 2 folder, the Cmd-C keystroke stopped working again, so clearly that is the problem.

Now the problem is that I have MANY of my own keystrokes. Is there any way I can figure out which of my own keystrokes is the one causing the problem without going through all of them one by one or resetting them all from scratch? (If there isn’t an alternative, I’ll just keep using Keyboard Maestro to make the Cmd-C keystroke work.)

And by the way, it had already occurred to me that the Key Commands file might be the problem, so I checked to see if I had accidentally put Cmd-C in as a Key Command — I hadn’t.

Thanks much.

If you zip up and attach your keycommands_en.json file here, I’ll take a look at it and see if I can figure it out.

Here it is, Daniel—thank you for being willing to go above and beyond!

Lew (9.56 KB)

You had explicitly deleted the Command-C shortcut from Edit > Copy. It should be restored in the attached version. (2.5 KB)

Good grief—I can’t imagine why/how I did that.

Thank you for finding it, and my apologies for…well, this whole thread. You shouldn’t have to spend your time babysitting.