HELP - Cubase 7.5 eLicence Control Center Problems

Hi everyone,

I recently purchased a copy of Cubase 7.5 with the intention of upgrading to Cubase 8. I’m running into problems when I try to input my product activation code for in the ELCC program that I installed to get the license key to work. The ELCC program recognizes my key, but when I input the activation code I receive the following message…

“Currently, there is no licence available which can be upgraded by your upgradeable licence. Please connect an USB-e Licencer, which holds an appropriate upgradeable licence, to your computer.”

I can see the USB e-Licencer in the “eLicensers” tab in the ELLC program, but next to both that device and the “Soft eLicencer” display a red circle with a diagonal line through it, indicating something is wrong… I WAS able to register the USB key on the Steinberg website, however.

Is there a driver for the actual USB key that needs to be installed? If so, a brief device driver manager popped up, seemed to execute itself fully, then went away… I’m on Windows 8.

Is there a Steinberg Tech or someone with similar ELLC problems knows what to do?

Thanks,
Brandon

Hi and welcome,

The driver for the USB-eLicenser comes with the eLicenser Control Center installer. Make sure, you have the latest version, please.

Is your USB-eLicenser plugged in to the USB2 port, please? Sometimes, USB3 makes troubles here.

Could you also try to unplug the USB-eLicenser and plug it in back, or even try another USB port?

First of all, you have to solve the issue with the red circle and diagonal line of the eLCC. This means, the USB-eLCC has not been recognised well. So all other messages could be affected by this.

Hi. I am having the same problems too. However there is one thing I would like to run by you. Did you fail to activate and register within the 25 hour time period? This is what I did and I think in doing so, locked out any chance of re-activating for permenent use. When I installed artist 7 it loaded up str8 away and was playing ok. Totally 4got about the 25 hour time trial lapse. Now when I try to open it I get a message to go around the houses, it seems, just like you I’m told to register when I try to put in the code I get those no entry error signs saying there are no products on this dongle or s/e licenser. Yet, both USB and Soft E-Licensers show up in the newly updated EL Centre and are both registered in mysteinberg. I don’t know what else to do. The Tech boys take too long to get back with an answer. If you have since solved your problem do let me know and if anyone else out there has had the same problem solve let me know.

Bless-ed all

Hi,

In this case, try to open the eLCC application, and choose Recover from the Actions menu.

The most common cause for this problem is a mismatch between the license you want to upgrade (the license that currently resides on your USB-eLicenser) and the upgrade license that requires a specific license to upgrade.

For example, if you own a “Cubase 7.5” license, and you want to upgrade to “Cubase 8”, you need a license that upgrades “Cubase 7.5” to “Cubase 8”. If you, by mistake, bought an upgrade license that upgrades e.g. “Cubase 7” to “Cubase 8”, this will not match your existing license and produce the error message you’ve reported.

Please have a look at the exact upgrade license description:

  • Open eLCC
  • Klick “Enter Activation Code”
  • Enter your Activation Code
    –> Below your Activation Code, you’ll see a description of the license that is required to be upgraded.
    –> Now check with the license that does exist on your USB-eLicenser.

In case you bought an incorrect upgrade license, you need to get reimbursed by the shop.

Hope this helps.

Hi, same problem here, im trying to activate c7 upgrade from c5 (and after i put the activation code it tells me its a c7 update from c4 c5 c6), and the upgrade came without a dongle (it says not required on the box), the elicencer softare is the newest, cubase 7 is installed and all other procedures went fine except when i put the activation code it shows me this message - I downloaded and installed the latest eLCC, and entered the activation code, but after that I can’t select my e-Licencer and I get the message :
Currently, there is no license available which can be upgraded by your upgrade license. Please connect an USB-eLicenser, which holds an appropriate upgradable license, to your computer’

Cubase 5 is registred as well.

Hi,

Do you have the Cubase 5 license on the same USB-eLicenser, where you want to activate the upgrade?

yes, its on the same dongle and its working fine, but when it becomes to upgrading cubase 5 becomes un-sellectable and its says no upgradable licence found…

i think the solution of the problem is the purchased product, from cubase studio 5 to cubase 7, i have attached the photos, do you think that can be it ?, since i tried everything else
IMAG2657_1.jpg
IMAG2653.jpg
IMAG2657_1.jpg

Hi,

But you own Cubase Studio 5, not Cubase 5 (as I can see on the box). Or am I wrong?

yes is that the problem ?, since there is no cubase studio 7, i dont think it exists, does it ?

Unfortunately, this is a problem, it is different Cubase version. There is Cubase Artist instead of Studio. It’s the same line, just different name.