HELP//Flow is doing something STRANGE

Any thoughts on how to fix this?

Or this??
Invisible Rests

Yes. First thing first: are those XML imports? If they are, could you go to Preferences > XML Import settings, untick everything, and re-import the files?

Second thing, if that doesn’t work: upload project

1 Like

So I exported the flows and tried to re-import (clicking “merge” every time) and same trouble arose. Ugly.

And now–and this is neat–I’ve tried to upload it here and it says my files contain zero bytes even though they look to contain far more. Any ideas?

First Idea: answer at this and try to do what suggested

Second idea: click (or right click I don’t remember) on the Dorico icon near the file name (top middle of the window), choose the containing folder, so you land on the correct folder in the Finder were the file lives. Does it say 0 bites? (Before uploading)

Well, thrillingly, now it is TOO BIG!

Do you think the wiser course of action is to work on the individual XML files as Dorico files and then import them at the last minute?

I’m sorry, I might sound a little bit numb… Could we take one problem at a time? You never answered my first post. Did you try re-importing the xml file with every option unticked in the Preferences >Impirt xml ? If so, do you find you still have those problems?
In your first answer, you say you re-exported the flows… From where? Why? I fear we lack some context. :person_shrugging:

Oh yes, @MarcLarcher, I did this and same issues.

Forgive me if I am being very stupid, but exactly what problems are you trying to fix? Your pictures tell me nothing. You mention issues - what issues?

I would like 1) like all the piano music to be in a piano part, one and 2) I would like to not have either the weird multiple staves in the center of my first picture or the empty staff sans rest atop the subsequent image.

The long row at the left of the first–pt 1, 3, Piano II &c, seems needless.

Does that help?

Ok. So there’s only one piano in your piece? You probably should do some tidying (copy paste to only one instrument if that’s what is needed) — usually when you use the Merge option when importing files, Dorico does a good job at recognizing piano instruments… But here, it’s messy. Note that in Layout options > Vertical spacing, you can set your layout to hide empty bars throughout the flow (here, first system seems excluded from that and it’s useless)

For the staff that lacks rests, invoke the caret at the start of the piece, top staff, shift-b, rest, enter. It should restore the rests there.

OK. In my experience, quite a lot of XMLs do not define piano (grand staff) instruments correctly. Dorico can only interpret them as two single staff instruments. These are all the Px instruments you see.

My method is:
Create a Dorico Piano score. Import an xml file, but do not merge players (It arrives as a new flow).
Add your piano to that flow.
Select one of the new (one staff) piano lines and use duplicate to staff to get the notes into your proper piano part.
Repeat for the other one.
Delete the surplus instruments in Setup.
Repeat for the next xml.


What if there are occasionally three staves?

Decide whether the 3rd belongs on the normal piano top or bottom stave and use Paste Special>Reduce… to merge the material as appropriate.