Help! Mic set up issues

I just bought the Focusright “Scarlett Solo Studio Pack”

I’m having problems with connecting the microphone within cubase. I have selected the Scarlett ASIO driver, when I try to record vocals it does seem to be working but I can’t hear anything back, I have my headphones plugged directly into my computer. In the “VST connections” “output” section the only option I have is the Scarlett, but when I plug my headphones directly into the Scarlett interface I hear only the vocals and not the rest of my mix. how do I make it so I hear my entire mix?

thank you!
Screen Shot 2015-12-06 at 4.36.18 PM.png
Screen Shot 2015-12-06 at 4.33.58 PM.png

You didnt mention any computer/software specs… those may help.

A few thoughts to start…
The other tracks in your mix:
The default output for Cubase midi and instrument tracks is the stereo out that looks like is set up correctly. These tracks do have to have a vst instrument assigned to them and an actual sound needs to be chosen. So, midi data needs a vst like Halion assigned and a sound like piano activated.

For audio tracks like your mic…
Each audio track output need to be assigned to that stereo out track. Look at how your mic’s audio track is setup.

All the assignments can be accomplished in the inspector section.

Cubase will not send sounds to your normal computer sound card. It only will work with an audio interface with an asio driver. Thats why only the Scarlet is listed.

Regards. :sunglasses:

@Ibidner,

Basically, all tracks go to Stereo Out, unless they go to a group or FX, but all must eventually route to Stereo Out to be heard.

It appears you have the full version of Cubase, which has Control Room, so you use the Studio panel of the VST Connections dialog to specify the particular physical connections of your interface to which monitors and headphones are connected.

Since the Control Room monitoring automatically uses the Stereo Out, they can be left as ‘No Connection’. The lesser versions, or if you disable the Control Room, require the _Stereo Out_s be set to the monitor outs on your interface.