Help. MIDI Issues.

Please help me. I have spent 500 dollars on apps to make music & am unable to do the simplest tasks that were no problem on my computer. I just bought Cubasis for the MIDI sequencing because I gave up on waiting for Auria to add it & the Genome sequencer is just awful. Now after trying out Cubasis, I’m having issues with getting MIDI from other apps. The input keyboard, like in all other apps is not very inspiring to play. I instead use apps like TC-Data & Lemur. However I am unable to get the MIDI from these to record into Cubasis. Same for iFretless, it is my favorite bass app & I love the note input method, but I can not get Cubasis to record its MIDI. What am I doing wrong that seemingly simple tasks are not working? I’m about to just dump iOS & ask Apple for a refund on this Cubasis, which is showing to be my latest disappointment. All I want to do is make music on a 21st century device like the iPad & I’m feeling completely let down & ripped off by the developers for all the money I’ve pumped into this platform for the past 4 months. This is ridiculous, please someone help me. It doesn’t help that these developers do not make it easy to contact them & if they do, they hardly respond with viable answers. I want to contact Steinberg directly, but it seems I can only use the forum for support, this I do not like either.

Feeling Scammed

Create a midi track
Select IAA, iFretless as an instrument
Arm the track to record
Switch to iFretless
Press record on the IAA control panel
Flail away

Works.
iPad Air, iOS 8.4, Cubasis 1.9.5, current iFretless Bass
image.jpg
image.jpg

Hi,

thanks for your help surfer and divisionmonarchy let us know if this solved the issue… if not I would be glad to investigate more and get this solved for you!

Thanks!
RG

I have no idea why, but I was doing this all last night. Exactly what you said & I could get nothing to work. Just trying it again & it seems to be working. Perhaps iOS really needs some more development with MIDI.

Did not not work for me first try this morning either. Then I realized I forgot to arm the the track for recording. :blush:

Ok, I’m still having issues. I’m trying to do this is Audiobus, not IAA. Cubasis IAA sucks & doesn’t recognize too many of my apps. I have a MIDI track with virtual MIDI in & out, but it is not recording the MIDI from iFretless. This is really frustrating. MIDI is a 30 year old standard protocol & Steinberg can’t get it right? I need it in Audiobus because I’m running iFretless thru Bias Amp & effects. Seriously, what is the issue here? It’s only MIDI.

Also, quantize ends does absolutely nothing. Funny how I’ve been working with midi for over 15 years & all of a sudden it’s like nothing works the way it’s supposed to anymore. Last I checked, you select a note, set your quantize division, check for quantize ends & fucking voila, it worked. Nope, not with this. What is the magic trick? It’s no problem in Ableton.

@divisionmanrchy - I had the same challenge with ifretless. I could record audio from it fine, but not midi. Had all the right boxes checked in ifretless, routing in the inspector but no joy. But if you follow @surfer 's directions it will work - the trick is load it as an Instrument (which I think in this case means it generates midi data) and not as a Generator. Then, provided you want sound out of ifretless too, add an audio(bus) track with ifretless as a Generator.

I can tell you are feeling pretty frustrated. I’ve got a couple of years using computers (Bars&Pipes, anyone?) and I have shared your feelings - why won’t that work?! In a lot of ways, it often feels like the hoops that had to be leapt through to make a music pc work back then. But for me, and I think others in the community, working through the challenges has ended up being rewarding, and maybe even made some music a little better. I tell myself I can go fire up Studio One anytime - but somehow I end up sticking with my apps and shiny piece of glass. It’s just inspiring, challenges aside.
You might like to visit the audiobus forum - it’s a great community and fantastic source of hands on info. If you’re having a challenge most likely someone there can help.
Best of luck

Don’t forget about MIDI Bridge…This can sometimes be used when all else fails. I use it when I want to direct MIDI from my LPK25 to my Beatstep.
It can be used for simple routing or for complex processing of MIDI (e.g channel swapping or filtering)
At first it does not feel intuitive or easy to use but if you are experienced MIDI user you will find your way quite quickly.

I have been having same thoughts about why is it so difficult in iOS, but when i think back to when i started with PC, it was the same, nothing seemed to work consistently. There were lots of little utility apps that made life easier, over time the utilities got built into the Sequencers and DAW’s until they all pretty much offered the same functionality (being led by innovations at Steinberg e.g VST).

When you do get frustrated, please remember that in comparison to PC, iOS is still very young, and IAA even younger. As long as there is a demand for it, the same will happen with iOS as happened with PC. It will become more stable, more functional and in the end we will all wonder how we used to manage with a PC and the limitations it has (noise, size, lack of real portability, electricity bills). My first midi studio took up a whole room and I needed a power board with 12 mains sockets, I now have the same functionality as I had then in an iPad mini 8 inches by 5 inches, running silently (not even clicks from mouse buttons) on a battery.

Stay strong and keep the faith :smiley:

Nice one, Andy! Thanks!

Good perspective Andy. Thank you. And thank you to everyone helping me. I guess I’m not so familiar with the early days of computers and music production because I was still using an MPC2000 and a Roland VS 16 track, so I waited a few years to jump into the game and I guess it was more smoothed out. The biggest frustration is I spent more money than I can keep track of to get all the cool apps so I can make music when I travel, which I’m doing for these months. I get an idea, feel so inspired and then the simplest things don’t work, I spend hours searching for answers and the moment leaves and nothing is resolved. That’s not what I agreed to spend my money on. If half these developers put more effort into the development as opposed to advertising and making videos of how great they are, maybe these apps would have better functionality. The worst offender of this is Retronyms and their dreadful and buggy iMPC, but they sure make great demo videos that made me want to buy it.

As a rule I ignore hype (as much as i can). If I am interested in an app what I do is look for negative comments on the official forums and check to see what the response to those negative comments are. The responses will tell you a lot about whether frustrations that current users are feeling are actual issues or if they are because they do not know how to use the app and whether real issues are being addressed or not.

Try this out and compare both Retronyms and AKAI to Steinberg. This will confirm to you that being here, as it always has been for computer based music production. is the right place to be :smiley:

Andy - I think I was trying to get at your same points, and I appreciate the eloquence you add!

divisionmonarchy - a better source of videos to watch would be thesoundtestroom. Doug often has a demo up within days of release, and it’s much easier to get a clear idea of what an app is really like! Or Youtubing user made tutorials of the app your interested in will often give a better picture as well.
A couple of tip ideas -
Audioshare could be your friend!- I have an Audiobus preset with 2 lanes; one is a drum machine routed to the speaker, and a second lane with an input of what ever app was inspiring feeding into audioshare - all specifically for catching an idea when I know I don’t want to be distracted by a DAW. Start the click, hit record, and now that riff is in AS and available whenever I have the time to work on it further. Plus the “Open In” in AS makes that a snap.

HTH

:laughing: :laughing: :laughing: @wigglelights
Iv’e never been called eloquent before :smiley: