Help Needed Recording Outboard Gear

I have what will probably be a stupid question to ask, and while it has probably been asked a million times I must be searching for the the wrong terms because I can’t find an answer.

I have recently purchased an SPL MixDream XP. Previously, my audio setup included a MOTU 24Ai, MOTU 16A, MOTU 828 all connected to a MOTU 1248 connected to my PC via Thunderbolt. This previous configuration was working perfectly in all versions of Cubase from SX3 up to 10.5.

I have a large amount of outboard gear that I record with, hence the different MOTUs. Everything has always worked perfectly while both crafting a song or doing a “Export Audio Mixdown”. I was bringing in all the analog channels and then mixing them in the box, and recording the master out. Worked perfect every time.

I then purchased this MixDream box and hooked it up to the 16A. All 16 outs sent to MixDream, one stereo pair for the return.

When I am editing/playing a project in Cubase it works perfect, and after playing around with things a bit I really do like the sound. I want to record this as my mixdown. Go to Export Audio Mixdown, name my file, start recording… none of the audio is being sent to the outs on the 16A, so of course the return pair is empty as well.

I have setup my projects as follows:

9 audio out busses created in audio connections (2 mono 7 stereo).
9 group channel tracks created to mimic these, all other channels are fed into the 9 group channel tracks.
Group channel tracks set to corresponding 16A outputs which all go to MixDream.

When I am editing a project and play it back, the audio from the group channels is fed to the 16A outputs which then goes to the MixDream which then comes back as the stereo pair fed into the master channel. And it works perfect every time.

However, when I go to record an audio mixdown, the audio from the group channel tracks is not sent to the audio outputs. I should say I am recording in real-time and I am not changing any settings compared to when I would record an in-the-box mix (which always works perfect).

I am sure I am missing some little setting or something, but If anybody out there has experienced this before, could you please share with me what I am missing?


By this do you mean the Export Audio Mixdown is set to Real Time? This is necessary if you didn’t record the processed signal to the Audio track before.

If you don’t record the return processed signal to the Audio track, the Audio Return track should keep the Monitor enabled. Is this the case?