Help needed syncing MIDI & audio

I’m sure this should be straightforward but I always seem to have problems with this. Any help would be much appreciated!

I am trying to transcribe a drum part. To do this I do the following:

  • Ascertain rough tempo of audio and set C6 to that.
  • Create a MIDI track and key in what I think the part is. This might be created as individual bars that I can easily duplicate as necessary.
  • Copy above and glue all bits together (just in case I want to go back).
  • Import audio track.
  • Check for descrepancies.

To do the latter I need the two tracks roughly in sync, e.g. so I can follow the score as I play the audio. This is not precision stuff!

I’ve tried using the ‘tempo detection panel’ to create a tempo track that follows the audio but it completely messes up the MIDI timing, i.e. bar lines are moved. This seems pretty stupid to me, but I don’t know how to stop it or what to do about it.

Almost certainly showing my ignorance here, for which I apologise. But I found no help in the manual…

Any ideas?

Rob

Make sure the MIDI tracks are in Linear Mode, not Musical.

Hi Robad -

If I understand you right, when you line up the starts of the audio and MIDI tracks, they are out of sync as they start playing?

There may be an easy fix, if your MIDI track is in “Musical Mode” (page 74 of the Ops Manual). If the inspector shows a little yellow/orange icon of a musical note (“Musical Mode”), toggle it to the grey “clock” icon, then see how well they stay in sync when you line up the starts. If it’s in Musical Mode, when you play the MIDI it will follow the tempo track, which could be a problem if the audio drums don’t.

Good luck! Let us know how it comes along.

:unamused:

Thanks for the help. This concept has always confused me!

The musical/linear button is displayed on audio tracks but not MIDI by default. I have added it. I thought maybe it had been replaced by the ‘drum map’ button…

But I fear your solution is not enough. For example, while waiting for a reply I have done my usual trick of syncing the audio to the MIDI using free warp. So everything is fine.

But… if I now analyse the audio to create a tempo track and activate that track it all goes out of sync. OK, actually it seems a bit unpredictable! In ‘musical mode’ I got the MIDI and audio completely misaligned. In ‘linear’ they are in sync but not with the bar lines - making the score unreadable! I’m pretty sure it also did something else but I can’t repeat it…

OK, congratulations, now the audio and MIDI are in sync with each other!

To get them to be in sync also with the grid you need to do an extra step. One way is to use Warp Tabs - page of the Op Manual. Basically what that does is stretch and pull the grid to match what you are playing. It then makes the score readable - the notes line up just right. It can be a little tricky to use, so I just have two pieces of advice if you haven’t used it much before:

  1. Always work on a copy of the file - keep the original LOCKED and for good measure even hidden in a folder track.

  2. CTRL-ALT-S is your friend (per Split’s post in the old cubase.net forum) - use it ALL the time, and even more often if possible! It’s not uncommon to make mistakes, and it’s really hard to undo things just right for some reason with Warp Tabs, as a quick read of the cubase.net forums will confirm. This way it’s pretty easy to just roll back to a previous version.

Some other random notes:

  1. This one can save hours: either put the clip at the origin (“Return to Zero”) point to work on, or - lock the beginning of the first note, “pinning” it to the grid (CTRL-click when putting a Warp Tab works for me, but I think the manual might say to do a SHIFT-click). Otherwise you can find you spend a lot of energy working on other parts of the piece, and then find the beginning has been “pulled” or “pushed” off its original starting point, making it out of sync at the start.

  2. Not necessary, but it helps if you can have set up the Tempo track, before you start, to roughly the tempo of the music you are working with. It just makes it a little easier to drag the Warp Tabs.

Good luck! Let us know how it goes -

Thanks for the help. But I’m not sure this is going where I want to be.

One of the reasons I upgraded to C6 was the new Tempo Detection facility. I assumed that, by using it to analyse an audio track, I would get a tempo track that sync’d C6 (and any MIDI tracks) to it. Is this not the case?

I have everything in sync because I used Free Warp to adjust the timing of the audio to match the grid. I have the tempo track deactivated! When I enable it everything changes except the sound! Mainly, the fixed tempo (103bpm) starts jumping around 200bpm! and the grid is out of sync. Otherwise playback seems unchanged. Presumably this is because I had already sync’d with free warp - implying to me that if I hadn’t, the tempo track would not be doing any sync’ing for me.

Sorry, dude, I feel your pain …

Those 200 bpm things sound familiar to me, in my experience they come from Warp tabs too close to one another.


From your first post, I think I understand your task is to transcribe audio drums onto sheet music. FWIW, here’s how I might approach your task - others with more experience will hopefully fill in with more efficient methods:

1) Make a tempo track that follows your audio, so your audio follows your sheet music bars.
To do this I would use Warp Tab, because so far I’m a one-trick pony. I don’t know if the “Free Warp” you did accomplishes the same task. I can’t speak to using the Tempo Detect tool either, as I haven’t used it much, maybe that would do it much easier. In any case, at the end of this step your audio should be able to be read nicely on sheet music.
2) Use the “Create MIDI Note” feature in C6 to generate MIDI from your audio - and thus follows your sheet music bars.
This is described in http://www.soundonsound.com/sos/apr11/articles/cubase-6.htm , “Multitrack Hits” section.

Does that do what you want? If not, sorry, hopefully someone smarter will come along and help you set things right!

Good luck -

Seems if I import the audio track, analyse it and set up the tempo track before creating the midi track all’s well.
But if I do the midi track first I can’t seem to get much sense out of it.
Once I exported the midi track and imported it as another track - that worked…