Help needed with Time Warp Tool


I have a piano piece recorded without a tempo or reference click. I’ve added another simple track to it, where the notes were aligned by ear to the piano track.

I need to rework the piece and use a grid. So I opened the Key Editor for the piano track, and used the Time Warp Tool to align the start of measures to the proper notes. This is very easy to do with the “Snap to Events” option.

However, when I come back to the Project Window, although I can see the edited tempo track with all the new tempo points, the other MIDI track isn’t aligned to the piano anymore.

I can’t use the Time Warp Tool directly in the Project Window because I don’t see the individual piano events. Am I doing something wrong?



It should be saved, of course.

You can do this in the Project window too. To see the Piano Events, open the In-Place Editor (I expect it’s MIDI).

Is your other MIDI track set to Musical Timebase?
And, on a more general note…
Depending upon the nature of the source material, especially if its tempo varies a lot, just because you line up the beginning of each bar to the grid, it doesn’t necessarily follow that all the beats within the bar will be nicely aligned. For this type of material, try to use the TimeWarp tool on every beat, or, better still, record a “tapping” MIDI track (i.e. your own personal click track), then use the option “Merge Tempo from Tapping”

Yes, they’re both set to musical timebase.

Anyway, I don’t know why, but it behaved just fine when I tried Martin.Jirsak’s suggestion and aligned the part using the In Place Editor instead of open the Key Editor. Worked like a charm.

Thanks a lot.