Help Please?! - faulty dongle

Hi - really hoping you can help…

I’ve bought a used version of Cubase 7 from a legit dealer on Ebay. He deleted his registration, and I’ve just gone to register it online - but when inserted - the dongle flashes, but nothing comes up in my control panel :open_mouth:
I’ve tried inserting other USBs and they appear immediately, and this problem is happening on my mac as well as my PC.

Is there anything I can do about this? Can I get a replacement from Steinberg?
I’ve contacted the dealer, but worried he may not get back…

Did you run the Elicenser Control Panel? If so, please provide a screen shot of the window.

Hi Steve,

sorry - where exactly do you mean? - I’ve created a Steinberg account, and in the ‘My Products’ section, chosen the ‘Register eLicenser’ tab where it asked me to enter my eLicenser number which I went to get from the (possibly) faulty dongle with no joy…any clues?

OK - just clicked on the eLicenser Control Panel link - do I need to ‘download the latest eLicenser Control Center’?..what does this do/what is it for/will it make my dongle work?!

SOLVED: Steve - thank you for pointing me in the right direction - I’ve now registered it.